Simulation Error for Daylight Simulation with Colibri


#1

Hi!

I am trying to do a parametric analysis that will run thousands of simulations.
Because of the problem of the disc space (raised here) that each simulation is requiring (around 500 Mb), I can not run big sets of simulations and the all purpose of leaving the machine to do its job is affected.

So I tried to use the colibri aggregator to save for each iteration the more info I could, and not keeping a copy of the simulation files by not saving each iteration with a different name.
The problem is that by doing this only the first iteration is run correctly and the data saved by the colibri aggregator, while the other iterations are either not run by the honeybee [+] run simulation component or not saved by the colibri aggregator.

Here a couple of screenshot of what I am talking about.
The first one is the error displayed by the run simulation componet.
The second one is the data.csv file that shows the -999 value that represents a data that has not be provided hence not recorded.

Any help would be very helpful.

best regards,

Federico


#2
  1. Why don’t you remove the temp folder as we discussed?
  2. You need to ensure to set reuseDMtx to False so Honeybee[+] doesn’t load the results of the previous study in the folder.

If you share your file it will probably be much easier to help you with these issues.


#3

Hi @mostapha,

thanks for taking time to reply.

  1. It is a good option and is gonna save tons of space. On the other hand, because the hd is limited, I would need to erase data several time and I will not be able to let run the simulations during the night.
    As a possible solution I was thinking on do not set the name of the simulations as parametric, so that the data will be saved in the same folder. The thing is that the data is not recorded on top of the previous data. Do you think that here there is the possibility to add an option to record on top the previous simulation?
    This will be useful in some cases.

  2. You are completely right, thanks for the advice. Actually I did not noticed this input and I was reusing the same sky coefficient although I was changing the epw. Thanks a lot.

When I set the toggle to false and run the simulations the error disappeared and the colibri registered the data perfectly. I tried with the toggle to true and also worked. Maybe the issue was the name of the file too long or grasshopper needed to restart. The case is that now I can see the data in the data.csv file generated by colibri. I also change to another computer, so maybe also this can be the issue.

In conclusion, I think that I will buy an external hd and save the simulations there erasing from time to time the temp and sky files that I do not need. Also I will use the colibri to save all the data possible, so I can analyze it easily.

A simplified version of the file is here.

Thanks very much for taking time to look at this.

Best regards,

Federico


#4

I think you have the original problem solved. Back to deleting the folder my suggestion was to add a component to delete the folder and not do it manually. Assuming path to the simulation folder is called folder this code should do it for you.

import os
tmp_folder = os.path.join(folder, 'tmp')
try:
    os.rmdir(tmp_folder)
except WindowsError:
    pass

#5

Thanks @mostapha for taking time to have a look at this.
As I am not into coding I will try to implement this and see if I can make it work.
Best regards and always thanks for the continuous support,

Federico