Annual profiles doesnt math with the point groups

Hello everybody,

I have some problem with reading the hourly(and annual)result when I have dynamic shading, it writes me that I have different number of point groups as annual profiles.

And I know that point groups are regarded to mesh etc. but this is a really siply testbox 10x10x3m ,where is just one floor (mesh). (above it is the chart for shading operation)

Can anybody help me with that ?

Thanks a lot

Peter

Hi Peter, Can you internalize the results and send me the file. Looks like a data management issue.Thanks,

  • Mostapha

Hi Mostapha, there is the file, I even send you a message with the model and other files,

Thank you very much

Regards

Peter

testbox0610_elchrom.gh (206 KB)

Hi Peter, I checked your file. You are adding a single point (center of the window) to test points which makes the number of test points not to match the number of mesh faces. Moreover, points are in different branches. If you are doing this intentionally then make sure to simplify the branches. -Mostapha

Hi, Mostapha
Yes I use it as sensor point, and I always flaten it to have them in one list, so I will try to just simplify it and let you know,

Thanks
Peter

Hi Mostapha,
so I tried the simplification and it doesn´t work, than I delete that one extra point and it doesn´t work too, can you please chceck it where can be the mistake ? the data is internalized

Thanks,

Peter

testbox_DA.gh (211 KB)

Hi Peter, I’m checking your file an I can see the check fails as you have more than one shading states. Let me see if I can fix it this evening. -Mostapha

Hi Mostapha,

Any results with fixing it ?

Thank,

Peter

Hi Peter. Sorry that it took me so long to get this fixed. Check the attached file for a fixed version. I had to make couple of modifications in components (The ones in red group). There is still a limitation for number of shading groups for visualization which shouldn’t be an issue in your case. Thanks for your patience.

-Mostapha

testbox0610_elchrom_msr.gh (189 KB)

Hi Mostapha,

You are amazing, it s totally fine for me now. Thank you for spending your time above it. So now the (red) components are changed on a github too or just in that file ?

Thanks again,

Peter

Hi Peter. It is updated on github.

Hi Mostapha,

Testing your file I’ve found a bug with the runDaylightAnalysis OR readAnnualResultsI components. I gave an input in the numOfCPUs (4). The simulation went fine but after it finished the readAnnualResultsI component complains about an unmatched number of points (1. Number of points in ill files: 10 doesn’t match the number of points in point files: 43). Running with 1 CPU is ok.

Or i’m missing something …

Thanks,

-A.

Thanks Abraham. This is a sorting bug. The files end up in the wrong branch. I will take a closer look tomorrow and let you know the results.

So I gave it another try. It takes some real code change to get this fixed for multi-thread run. I re-opened the issue and will hopefully fix it during one of the coming weekends. Meanwhile you need to run it on a single thread:

https://github.com/mostaphaRoudsari/Honeybee/issues/213#issuecommen…

Thanks.

-A.

Hi Peter and Abraham,

I think I have this thing finally fixed [By think I mean I hope!]

Can you please try the attached file and let me know if it works fine for you now. I’m so ready to see there is still something missing! I wish Daysim was a little bit more user-friendly.

If this once works fine then next move is to address Peter’s wish (https://github.com/mostaphaRoudsari/Honeybee/issues/236).

Thanks,

Mostapha

testbox0610_elchrom_msr_2.gh (494 KB)

Hi Mostapha,

Not good news from me.

Taking your file as is, and setting the _writeRad to True gives the following red error message:

  1. Solution exception:pop off of empty list

And after that no much left to do/check :slight_smile:

-A.

Hi guys,

Better news from me,

It worked for me,

but when I want to re-read the results, I cannot sort the list of ill files as the runDalyightanalysis made it, so I can´t read it back,see attached file

P.S. I have just 2 cores.

testbox0610_elchrom_pz_2.gh (509 KB)

Abraham, I cannot reproduce the error. Can you tell me which line of the code is that? Can it be because you are using a weather file that has a problematic heading? I rarely use List.pop()

Peter, I have also updated LookUp component last night so if you use the newest one on githiub it should give you the same structure.

You are both awesome! Thank you for checking this almost real time. :slight_smile:

Mostapha

testbox0610_elchrom_pz_2_msr.gh (509 KB)

Hi Mostapha,

Somehow another reply i (think) i sent doesn’t show here. So the problem i mentioned is not anymore. It was a mistake from my side (picked a stat file instead epw).

I’ll check the new file in a bit …

-A.