Bar chart not baking legend

Dear LB community,

Have you faced this before that Ladybug Monthly Bar Chart does not bake the legend by setting the bakeIt_ input to true?


Are you using Rhino 6?

Yes @devang, I am using latest Rhino 6.

Please use the component in this file and share if it works fine. (392.9 KB)

Thanks @devang. But with this updated barchart, setting the baking to true crashes the component.

I attach my file, in case you have time to have a look at it. If you just run EnergyPlus on the centre of the canvas, you can see that the bar chart at the bottom right hand side of the canvas crashes.

Farhang (862.3 KB)

Thanks for the file. I will look into it

Hi, I wanted to confirm that this produces the same error for me.
But if I bake by right clicking then it works:

1 Like

I tried the file provided by @farhang.tahmasebi. It works without error at my end. I tried on two machines. Following is the rhino version.
Version 6 SR22
Can you please share what’s the error message?

@Devang, the error was this one:

  1. Solution exception:‘NoneType’ object is not iterable

But as I tried to replicate the situation, I realised if I save the file with the updated Barchart, restart Rhino and open the file again, it will work. I hope this helps you if any refinement is necessary.

I wonder, how we can access this updated barchart in .ghuser format? Perhaps if it is included in user objects folder and loaded from the beginning, it will work without this issue.


If I save after updating HB Components it does not produce error any more, but it does not bake it still (866.5 KB)

@ae did you set the BakeIt input toggle to true and turn on the Ladybug layer in Rhino?

1 Like

Turning on the layer solved it :slight_smile: did not think about this!