Beginner user issue HoneyBee goes GH ultra-paranoid mode

Hi everyone,

Firstly thank you to Mostapha for your App/Works. I’m trying to learn LHHB and it’s use by GH, i’m a beginner user so maybe it was my fault, when i run 000_GettingStarted_With_Honeybee.gh file i’ve this issue:

it’s seems because of EmbryoViz issue (but i can’t understand). Perhaps it will be my “goofy error”, however i hope someone will help me. Thank you.

Hi Jack,

It’s not just you. I am also able to replicate the problem. It seems to crash in the following case:

  1. Open the tutorial file that has the EmbryoViz graph already placed. The graph component should not be connected to anything.

  2. Connect some null data to the graph. The component crashes as shown.

2b) Alternatively, connect a list of numbers to the graph. The component does not crash, but remains grey and fails to generate the graph.

Interestingly, the component doesn’t crash if you start a new canvas, add the graph component, save, reload the canvas and repeat the steps above.

Also, the component doesn’t crash if you add your own copy of the graph component to GH and then feed data into it. See my attached file - the component on the right I added myself.

So I’m not exactly sure what the problem is - it isn’t exclusively a problem with EmbryoViz, but likely some kind of clash between HoneyBee and EmbryoViz. May be worth contacting John Harding (creator of EmbryoViz).

In the meantime, when you load the tutorial file, just delete and re-add the graph component from the canvas.

James




Firstly thank you for your timely answer,

I’ve made some attempts about points 1),2),2b). The component doesn’t crash, but i still see this bleeding component:

while in the imagedBasedSimulation directory it seems to be ok, indeed i see a little HDRimage preview, but not GIF (is it because of "those kind of clash between HB & EmbryoViz?).

Hi Jack,

There is no clash between Honeybee and EmbryoViz per se. It is only that PathToImage component doesn’t handle empty inputs.

In your example HDR2GIF component fails to create the gif file. Can you check the balloon on top-right corner of the HDR2GIF component and see what is the issue there?

Mostapha

Oops, that’s what I get for looking at this at 2am in the morning - it’s an image component that’s crashing, not a graph component. The image component crashes quite reliably whenever it’s fed a null input, regardless of what else is going on around it. I retract the comment about clashes between EmbryoViz and HB. Sorry!

Hi Mostapha,

baloon text displays:

  1. Failed to genearate the .gif file. Open the bat file with a text editor and change the last line from exit to pause. Then run it again and see what is the error.
    here is the file address: c:/ladybug/myFirstSimulation/imageBasedSimulation//HDR2GIF.BAT

Then i’ve run .BAT (after edit it), here the pic:

Hi Jack, Can you set _adjustExposure to False and try again. The error massage happens in pcond line which is the line that set the exposure of the image.

Hi Mostapha, thanks for your effort.

I followed your indication but the result was the same even if i use the component HDR>TIF (both with toggle set to false) :frowning:

Hi Jack. I can’t check the files right now so I can’t really help that much. I hope someone else from the list can help you soon. In any case I’ll try to get back to you once I have access to my laptop.
Mostapha

Hi Jack,

Since Mostapha’s suggestions are now working for you (and he is on the road) i would suggest two things: Upload the file in question (with internalised data) and/or check backwards the components to see where the process is failing. I suspect that even the HDR image was not created (from your images it’s not possible to say).

In general i think is always better to attach the file so the advice can be more productive and fast.

-A.

Hi and thanks Mostapha and Abraham Yezioro. I linked my GH file (it’s the first about HB tutorial) and HDR generated (only in the destination directory but not display in GH through HDR>GIF, HDR>TIF component).

000_GettingStarted_With_Honeybee.gh (360 KB)
myFirstSimulation_RAD_Perspective.HDR (64.6 KB)
myFirstSimulation_RAD_Perspective_h.HDR (981 Bytes)

Hi Jack,

Attached a working version of your file. See the yellow frames in the file to see what i changed/added. The first one didn’t affect the result but as a question of “good behaviour” define the type of camera and the type of render. The second one worked for your case, though right now i’m not sure why it worked well. It only re-render the picture adjusting the exposure. I didn’t think it is supposed to affect that much. The only thing is maybe that you are using a previous “old” version (the release version). You can see that the second yellow have more updated dates in the components. I added another group where you can update automatically the file to the last repository in the github both the file and the library of components. Just be careful with this one since there are some components that change the names of the inputs/outputs or the numbers of inputs and outputs. Those are not updated properly in the document, so you need to insert the updated component from the menu and reconnect the whole thing.

Probably Mostapha can explain much better than i did, but in the meantime you can run (or walk).

-A.

000_GettingStarted_With_Honeybee_A.gh (373 KB)

Updated the file to the last version and it works fine.

-A.

000_GettingStarted_With_Honeybee_A1.gh (391 KB)

Thank you Abraham for your effort and your advice (about good behaviour to improve my workflow). I did a lot of attempts:

  1. update my GH to last version; (after tried to run your GH_A version file)

  1. updated LHHB files by tour “update component” (because i’ve noticed from this link https://app.box.com/s/02d7kp230vb045i9j4ix there’s old version yet)

3)I replaced every component with the new ones (HB 0.53).

The result is the same, HDR>GIF componet displays:

  1. Failed to genearate the .gif file. Open the bat file with a text editor and change the last line from exit to pause. Then run it again and see what is the error.
    here is the file address: c:/ladybug//JackTest053/imageBasedSimulation//HDR2GIF.BAT

Maybe it’s me, but i’ve noticed the HDR>HDR path it isn’t the right path, then when i connect HDR>HDR output to EmbryoViz it doesn’t crash (or display the bleeding window) but display this error baloon:

  1. Path must be a valid location

at this point i suppose (it’s only a beginner user opinion) it could be the wrong output path the real problem?

… so weird. It works for me fine. See attached. I tested 3 options: “My” way, “Your” way and inputting the file path by a panel. All of them are ok, even that for the first two the path show the slash in the opposite direction.

The question now is if the images really are in the output directory. Can you see them? Just want to be sure this is not only a display problem.

Also, sorry for the question, but, are you sending the perspective view for calculation? Or is it the plan, side view?

-A.


EmbryoViz seems to be ok (i only put the path of your GIF image):

i see the HDR file and i send perspective view for calculation. I’ll send you a PM with a little movieclip.

Jack, I saw the video. I have 2 comments (not very helpful right now): 1. As Mostapha said, their is a problem converting the HDR to gif (or tif, as you said previously you tried). Changing the expo

Hi Luciano and Abraham, Did you guys get this fixed or is it still an open issue? -Mostapha

Hi Mostapha,

I believe it is still open, but can’t tell for sure. I asked Luciano (Jack?) to upload the directory contents where all the stuff is done but he didn’t so far. I can’t reproduce his error, so i wanted to see that all files arr fine. Can’t think what else to suggest before seeing that.

-A.

Hi Abraham and Mostapha, i have still the same issue unfortunately. At this moment i’m not at home, i’ll attach my gh file again as soon as i come back home. Thank you for your interest very much.

P.S. Sorry for the name, i’ve updated my profile after we started this thread. :slight_smile: