CumulativeskyMTX Error

Hi,

I have a problem with cumulative sky MTX.

In attached you can find two images about this problem.

Thanks

Andrea




Hi Andrea,

I think I need more information to be able to help you. Can you connect the readMe outputs to a panel and let me know what does it say.

Did you select a valid weather file as the input?

768ms for genCumulativeSky doesn’t look right. It my fail to download gendaymtx.exe on your drive. Something should fail in that component. If you capture an image similar to image below it should be easy to fix your problem.

Hi Mostapha,

thanks for your help. In attached you can find an image with panel.

The weather file should be right because I am using the same file in sun path component and working correctly.

Thanks

Andrea


Looks like the first run wasn’t successful and now the component reads the wrong file every time. Set useOldRes_ to False so the component re-run the analysis. Let me know if it solves the problem.

The first problem should be solved, the wheather file run good. But probably selectsky mtx doesn’t work and another problem is DOY-HOY component (the line is orange and usually when i connect this component slectskymtx become red).

I don’t know is very strange!


Hi Andrea, It is strange indeed.

I have no idea why the output for HOY is empty in your image. It shouldn’t be. I downloaded and tested it for Milan and it works fine on my system. The only other suggestion I have is to change the working directory.

Do you have reading/writing access to C drive? Something goes wrong with genCumulativeSky component. It is either an issue with downloading gendaymtx.exe or with running the batch file. Do you see a batch file similar like this pop up and stay for a minute or so?

Thank you, I solved the problem. There was a problem with directory. I will try to do some analysis.

Compliments for ladybug is a fantastic plug-in.

bye.