Curved surface not accepted by HB[+] HBSurface component

daylight

#1

There seems to be a problem with curved surfaces for the HBSurface component in HB[+]. By the way, the surface is planar and the HB legacy component has no problem accepting the same surface. I attach here a gh file with the surface i am referring to. HB[+] version is the latest.

Anybody getting the same error ? : 1. Solution exception:Attempted to divide by zero.

curved_geometry.gh (8.4 KB)


#2

@IasonBournas, To avoid the issue You can recreate surface like this:


#3

@OmidmRashidi, Thanks for taking the time and for your input,
i was trying to avoid subdividing the arc etc., as there are multiple surfaces like that in different lists that also contain ordinary surfaces, making it really time inefficient to do this per surface. I was wondering if @mostapha knew how to solve this within the component, if possible.


#4

@IasonBournas ,

Honeybee[+] does not yet support curved brep geometries and so you have two options for these types of situations:

  1. Planarize your geometry using methods like what @OmidmRashidi has posted.
  2. Mesh the geometry yourself with native GH components and plug the resulting mesh into the HBSurface component.

The second one might be best for daylight simulations since increasing the number of mesh faces using Rhino’s automated meshing won’t drastically increase the calculation time. However, when we eventually add in energy modeling capabilities into HB[+], you will probably want to do option 1. since using Rhino’s automated meshing can create a lot of surfaces that will greatly increase the calculation time.

I think that we will eventually build option 2 into the component so that you don’t always have to mesh it yourself if you do not want to.


#5

Thanks @chris, so we will wait for the built-in option to come in the future.

For anyone reading this, if you want to solve it manually, passing the brep data through a “mesh” component solves it, as well as @OmidmRashidi 's way shown above.