DaylightControl SensorPoint Issue

Hi,
I think i’ve found a bug with the sensor_points in the DaylightControl component.
When i have a room at ground level, i defined manually sensor points at 0.8 m height.
When i check the IDF file i see that the point are located at 2.8 m height.

When i duplicate the room to make a building, i also duplicate and move the points. Those are located ok Meaning the issue happens only on the ground. Weird.
Attached the file to replicate the issue.

Thanks,
-A.
DaylightControl_SensorPoint_Issue.gh (80.1 KB)

Hey @AbrahamYezioro ,

I opened your file but I’m unable to recreate the error:

However, if you are duplicating and moving Rooms in your original file, I think I know how you were able to create this issue. Let me see if there’s a bug in my code.

Yep, there was a bug in the room duplicating and moving process. I just pushed a fix:

Once you run the LB Versioner, you shouldn’t experience this issue again.

2 Likes

Hi @chris,
Thanks, but … unfortunately the issue persists:


I thing that the Z value for the original rooms is “accumulating” a value or keeps a previous value in memory. It happened that at some tests the value is incrementing by the height. I needed to recompute the solution, but still, after that, it is still incorrect as the image above shows.
I wasn’t sure, after your fix, what i need to connect to the second solveAdjacencies. I tried both options but no change on the z values of the original rooms.

Attached the file which i’m testing that creates the issue.
DaylightControl_SensorPoint_Issue_01.gh (85.6 KB)

Thanks,
-A.

Yes. This is definitely happening. When i change the floor height, the original rooms’s sensor Z value is adding the value each time.


EDIT*
Also found that the IDF created for the AnnualLoads is different than the one for the ModelToOSM, like so:

There you can see the Z values of the first floor are different.
-A.

Yes, that’s the bug that I thought I just fixed. Are you sure that you ran the LB Versioner after 12:30 AM Eastern time in the US? It took the fix a few minutes to become available with the Versioner after I posted it last night.

I can’t recreate this situation when I update the libraries:

DaylightControl_SensorPoint_Issue_CWM.gh (89.8 KB)

1 Like

YES you did!! I did update after i saw in the github it was there. But probably it didn’t download the correct version. I ran the Versioner now and it works as it is supposed to. Tried to break it with no success. I need to wait a bit more next time.
Thanks @chris!!
-A.

1 Like