Different results for one situation

hi guys,

when I run daylight simulation one more time without changing the input data, I got different results.

as shown here, these are three different results of one situation, that I ran immediately after each other with no changes. this seems strange to me.

thank you in advance for telling me whats wrong about it.

-masoumeh


It’s normal specially if Radiance parameters are set low. Search Grasshopper for “Stochastic Radiance” and you will find similar discussions.

thank you mostafa, learning this “Stochastic Sampling” was intresting for me!

Hi Mostapha,


I found out on another forum that it’s possible to add a -u to the Radiance string in order to turn off the stochastic randomness. Is it possible to do it with HoneyBee as well?
I tried to put the “-u” into the _additionalIP input but it doesn’t work.

Thanks in advance,
Claudio

Hi Claudio,

Definitely a limitation on our side. Radiance parameters only works for parameters that has a value to be set. Let me see what would be the best way to implement it to Honeybee RADParameters. I’ll keep you posted.

https://github.com/mostaphaRoudsari/Honeybee/issues/433

Hi Claudio,

I added the functionality. Now you can add other additional parameters such as -u, -bv, -dv and -w. Give it a try and let me know if it works as expected.

Cheers,

Mostapha

Hi Mostapha,

After a very short test I would say that it works fine. I’ll let you know if I’ll find bugs in the future. Thanks for adding it. I run optimization processes and it’s good to be able to turn ON/OFF the randomness.

Now we’re able to close quickly the discussions like this one, started by masoumehta, just with a symple “it’s Radiance randomness, just put a -u”. And give a solution to people that struggle with it.

Regards,
Claudio

Hi,

Is this possibility for adjusting randomness removed in the new version of honeybee?