E+ Orientation

Has anyone gotten the “north” parameter to work in the Run Energy Simulation component? I was just trying to rotate the orientation a simple zone and found that I got identical results no matter the number or vector input for north. I also got this warning in the output:

** Warning ** GetSurfaceData: World Coordinate System selected. Any non-zero Building/Zone North Axes or non-zero Zone Origins are ignored.

After some troubleshooting, I found that HB set the E+ coordinate system to world, but that for the north parameter to function it needs to be set to “relative”. When I manually set the coordinate system in the IDF editor to relative, the North Axis rotation worked as expected.

I’m attaching the GH file I was using. Perhaps I set something incorrectly?

Thanks for your help!

03_NorthPar.gh (502 KB)

Hi Burin,

The warning is in the level of zones so it doesn’t really matter.

I will check your file to see how are you doing it. My best guess is that you are rotating Honeybee geometries which is not the right approach (here) and (here).


Hi Burin,

It was an issue on our side. You set everything right in your model.

Apparently EP also overwrites north direction in level of buildings once coordinate system is set to absolute. I changed the system to relative and it works fine now. Thank you for reporting this. Fixed both on github and the attached file.


03_NorthPar_msr.gh (536 KB)

Hi Mostapha,

I am having the same problem as Burin, but when I update the components in the canvas the simulation wonr run because other components stopped working:

EP Output: 1. Solution exception:global name ‘comfortMapVariables_’ is not defined

Glazing Parameters list: 1. Solution exception:name ‘northGlzParam’ is not definedGlazing Based on Ratio: 1. Solution exception:name ‘splitGlzVertDist_’ is not defined

RAD Parameters: 1. Solution exception:name ‘additionalP_’ is not defined

Also, is it possible to change the orientation of the geometry for the daylighting simulation in a similar way?

Thank you,


Hi Blanca,

Make sure that you alse updated userObjects and then replace the components with new ones from the Ladybug/Honeybee tabs. That should solve the issue. Update components has limitations when number of inputs or name of one of inputs is changed.


Thanks Mostapha,

If I replace the components qith new ones from the Tabs the date and version of the components go back to the previous ones and a new error comes up for the Run Energy Simulation component (1. Solution exception:too many values to unpack).

Everything seems to work fine on the file you uploaded, but again, it is using different component versions.

Thank you for the help, I attached the file in case it is useful.

test.gh (553 KB)

I believe that’s because you haven’t updated the userObjects, and just updated the file. Try this file.

update_userObjects.gh (416 KB)

Thanks Mostapha! I missed that option.

Is there a way to change the orientation in a similar way for Daylighting simulations?



If it’s not an annual simulation, skies has a similar input for north. It hasn’t been implemented for annual analysis so you need to rotate the geometry itself.

That would be a very useful input for annual simulations too:)

Thanks for all your help,