EnergyPlus error - Wrong Object Type

energyplus

#1

Hello,

I have a model that is running completely fine on one computer (despite the fact that the model has many flaws, but I don’t think it matters as the following issue happens regardless of the complexity of the model) but I get the error as shown in the picture on my other PC. I am pretty sure that I have the same setup on both computers and I have tried reinstalling Rhino and all the plugins countless times. One thing that I notice is that after every installation when I try to open the file, it says that Honeybee couldn’t find “Item Selector” and the program won’t run fine unless it’s installed. I’ve looked it up and installed it throwing “ItemSelector.gha” at grasshopper but nothing seems to change. Any help is appreciated. Just to be clear, I am not concerned that the results of this simulation are meaningless due to the faulty setup in the model. I just want to be able to RUN the simulation on this PC, whereas is works just fine on the other one.


#2

I can’t seem to be able to upload the grasshopper file as I am a new member. I will gladly do so if permitted.


#3

Hi @israelsolha

Since you mentioned there is a problem with “ItemSelector”, I’d suggest you to replace it with “List Item” on the computer that works fine. Once you replace all "itemSelector"s, try to run this on your current computer to see if everything works fine, and check if there is a “Fatal” error (use “panel” to check all errors).


#4

That’s the thing, even though I am getting this error loading the file, there is no such function being used in the code itself.


#5

I managed to fix the Item Selector problem, but now everytime I install Rhino and try to run the program THE FIRST TIME I get this error. After closing it and opening it once again I get back to the error shown in the first picture. It seems like it has something to do with the Analysis Period but it is set to default. Does it even make sense to only have an error on the first try after installing and from then on it changing to another one?


#6

It looks like a version mismatch. The changes in EnergyPlus objects for RunningPeriod are causing these errors. The latest version of Honeybee should work fine with OpenStudio 2.5.

cc: @chris


#7

Thank you so much. Reinstalling everything with openstudio 2.5 solved all my problems!