Error with HB_indoor radiant temperature map

Hi,

I had the following error in this script to find out the MRT distribution in a room:

"1. None of the connected srfIndoorTemp could be matched with the connected surface names and view factors. Note that this component does not currenlty work for curved geometry E+ simulations because the surfaces are broken up and meshed in order to run it through E+."

The thing is it worked the first time I run the simulation but then I changed some parameters and I have not been able to make it work again.

141110_Mean Radiant Temperature - grid over a room error.gh (175 KB)

Hi alejandro,

Just disconnect the typical cold week from the MRT component, it worked for me

You are right, I disconnected it the analysis period from the “IRTM” component, and now it works. I guess it is enough to set an analysis period in the “Run Energy simulation” component.

Cheers!

Ale

Alejandro,

Thanks for finding this. I blank out the analysisPeriod input in the case where EnergyPlus simulation results are not annual to try to show that this input only works for annual energy simulation results. However, the component should not go red like that in the case that you do hook up an analysis period. It is not going red on my system and I am not sure why:

I guess it’s really not much of an issue but let me know if you get it to work with the analysis period still plugged in.

-Chris

Hi Chris,

It worked fine in my end as is. No need to disconnect anything.

HI Chris,

So I have error like this: too many values to unpack ?! And soo ,the strange thing is sometimes I have this error and than I just rerun the simulatin and it disapears but e.g. when i change the HOY (step of simulation) it appears again.

And the file from Ale, runs for me with the connected analysis period also (but sometimes I have the same error as he had), and even I had one more error like the geometry is not closed…and it happens when I made the geometry from surfaces, but I know that it was closed. so maybe our OS or PC don´t want to cooperate with us :smiley: :slight_smile:

regards

Peter

Peter,

Thank you for posting a detailed response and I believe that I have discovered what the issue is in your case. I should be clear that this seems to be different from the issue that Alejandro was first experiencing, which I think was the result of the names of surfaces changing in different runs of his energy simulations.

I your case, Peter, I believe that it results from using an old Indoor Radiant Temperature Map component with a new Ladybug_Ladybug. A couple of weeks ago, I put some new text formatting functions into Ladybug_Ladybug, which makes things like the text of legends and titles display more nicely in the Rhino scene. I know that it will cause that “too many values to unpack” error if it is used with old components that have legends.

As long as you input zones that are closed into the view factor component, you should not get an error that tells you otherwise. I know that, with the surface-by-surface method, I sometimes mistakenly make zones that are not closed because certain surfaces are grafted when I input them into the createHBZones component. Could this be what is happening in your case?

-Chris

Hi Chris,

Yesterday I had the same erro as Ale had with the srfNames, but now I cannot redo it. And the surface by surface geometry-i had “closed Brep” output from the crate HBzones component so that´s why was I surprised.

regards

Peter

Hi Peter,

I have tried to recreate Ale’s error and I can’t seem to do it either. For now, let’s take your, my, and Abraham’s inability to replicate it as a sign that it happens rarely and can be fixed quickly

I was not able to replicate your issue with closed geometry using the surface-by-surface method. If it happens again, please send me the file. In the meantime, I am going to be adding in some features to the ViewFactor component this weekend and it may be worth testing again after this new, suped-up version is complete.

-Chris

Hi Chris,

Ok, if that problem appears again , I will send it.

and cool it will be a pleasure to test it a lil bit :slight_smile:

regads

Peter

Hi Chris,

I’m having a problem with the RadiantTempMap component. It is complaining about Runtime error (KeyNotFoundException): srfTemp.

The attached file is only one zone of a more complex building. Tried to isolate the problem, since the whole building is, of course, not working either. In the file i reconstructed the whole surfaces and zo nes definitions (it is based on an imported geometry from sketchup, and i rebuild using surfaces). For the whole building the suggested error was related to the Tolerance of the model. This is not the case in the attached/single zone.

What am i missing?

I’m attaching also the whole building file, but just be aware that the simulation can take a few minutes …

Thanks,

-A.

Caldwell-TestOneZone.gh (517 KB)
Caldwell_01.gh (1.02 MB)

Abraham,

I am currently in the middle of a major revision of this component to include the effects of sunlight falling on occupants and the option to input different surfaces to do the view factor calculation. I will test your file with the updated versions once I finish them either today or tomorrow.

-Chris

Hi Abraham,

I’m sorry to finally respond to this issue so incredibly late. I am still in the process of re-vamping the radiant temperature map component and working it into a big workflow to evaluate sub-zone comfort. However, I am at a milestone now and I can rest and check your issue. It seems that it was happening because of a naming convention that Mostapha was using for glazed surfaces that I have since fixed. This was causing both the “Color Surfaces” component to not display the windows and the indoor MRT map to fail.

Needless to say, I put in all of the most recent versions of the components into your file, everything now works perfectly:

Let me know if you run into any other issues and thanks for finding this one!

-Chris

CaldwellTestOneZone_CWM.gh (536 KB)

Thanks Chris,
You are the best. Works, as you say: perfectly.
-A.