Failed to load from empty file

radiance
daylight
honeybee

#1

Hi I have been trying to experiment with “blind states” using the 3-phase method.
Here is how I have my glazing setup

Once I start my analysis run everything seems to be going fine for a bit. then it just stops and gives me an error of “failed to load from empty file”

I saw a link to another post with the exact same issue. https://github.com/ladybug-tools/honeybee-grasshopper/issues/12
In that post the issue was resolved. The issue for that user was his version of Radiance not being current. I Just updated to honeybee+ 04. The installer says "ensure Radiance 5.1.0 or higher.

I am currently using version 5.1 Yet I still have this issue

image

Any suggestions on how to resolve this issue would be greatly appreciated.

Thanks in advance!


#2

In your case it seems the analysis is ran successfully and it loads several other values for other spaces and fails for the last one. Can you share the Grasshopper file or zip the analysis folder and upload it somewhere and share the link?


#3

BlindStates_TESt.gh (530.7 KB)
Glass_45Vt.xml (138.2 KB)

shade__5vt.xml (138.2 KB)

Just so you know I changed the building geometry in the definition to a simplified box. Originally I had a multi floor space. Not sure if that will make a difference.

Thanks Mostapha!


#4

The issue is with the input BSDF files. The RowAngleBasis is not Klems Full and that makes an issue when matrix multiplication happens. Honeybee assumes your input xml is Klems Full and sets it up in rfluxmtx header. You can see the setting in SouthWindows..glw.rad.

I will write more about this later tonight or tomorrow.


#5

It is one of those cases that it was easier to implement rather than explain why it is happening. If you update the installation using the component under developer panel your file should run with no issues:

Also 900 points is way too many for a case like this and will make Grasshopper to run out of memory. Until we implement the database you should keep the number of points in a lower range.


#6

Thanks Mostapha

I created those XMLs with LBNL Window. Is there a tutorial anywhere on how to generate a full Klems file with LBNL window 6 or 7. I could not find any info in the Window supporting docs. but I did see that their is a tutorial by Andy McNeil for generating them using genBSDF. Is their any other way to generate them?


#7

I’m not the best person to answer this question but from what I can see in this reply from @chris there is a dropdown to set the angle basis: Simulate light diffusing materials

In any case, if you update your installation now Honeybee[+] should be able to handle klems full, half or quarter with now issues. The only limitation is that the BSDF materials used for the different states of each window group should have the same angle basis. For instance you can’t have a klems quarter for the first state and then use a klems full for the next state of the same window group.


#8

Thanks again @mostapha !

I will check out the reply from @chris in that post.

I truly appreciate all the work you guys do.


#9

Sure thing! Thank you for taking the time to report the issues. Always be happy to help.