Having trouble installing butterfly

Dear Group,

I’m trying to use butterfyl now. I’m almost sure I installed OpenFoam properly. But when I open the installer in grasshopper, here comes an error as below. Is there anyother way to install Butterfly? Like for ladybug and honeybee, we can copy paste files to user objects folder.

Appreciate for your help!

Thanks,

Chenyang

Chenyang, Disconnect the boolean from butterflyFolder input. Butterfly is different from ladybug and honeybee and needs to download the python libraries to your machine. Then you can copy the userobjects if you want. Read more here. Hope it helps.

Hi Mostapha,

Disconnect doesn’t work! I realized Chrome doesn’t allow me to access github! It’s really weird! Other web sites wok fine! Do you have any idea how I can do with it? That’s probably why I can’t use installer.

Thanks,

Chenyang

Hi Chenyang, Do you think that you can access github at some point soon? Did you try other browsers such as FireFox? Otherwise I can attach the files here and you can copy them manually.

I fixed the problem. I can access github now, but I still can’t install butterfly. Same error! How can I do it manually? I would like to try. Can’t wait to try butterfly!

Chenyang

You need to set update_ input to True and leave the first input empty. Have you tried that?

I tried. It doesn’t work.

Chenyang

What’s the error message? If you share the error message I can hopefully get it fixed for you.

Ok! I checked the line number. The issue is that there is no scripts folder in sys.path on your machine. Can you run this in a python component and let me know the results.

import sys

for p in sys.path:

print p

I am not sure if I did this right, but result is

"C:\Users\Chenyang\Downloads

c:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins\IronPython\Lib
C:\Users\Chenyang\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins\IronPython (814d908a-e25c-493d-97e9-ee3861957f49)\settings\lib"

And the picture below is how I did.

Thank you so much!

Chenyang

Thanks Chenyang! Can you try the attached file? I added an option to check for other folders if scripts folder is not available.

installer_updated.gh (5.36 KB)

Thank you for your attachment! It’s working now! Can’t wait to try more function!

Chenyang