Honeybee + E-Plus - Surface Boundary settings

I second all folks here by thanking Mostapha and all for the outstanding work…

I am working on Honeybee and EnergyPlus, and I have an issue.

I created a zone using surfaces, and it all works fine. However I need to set few surfaces as adiabatic (see the attachment).

When I run E-Plus simulation, it gives as warning that the surfaces are marked as Outdoor, which is a mistake. I’ve dug into the IDF log, and E-Plus override the settings for these surfaces.

Is there a way to spec no Sun Exposure in Honeybee?

Thank you in advance.

-berardo


Hi Berardo,

Thank you for kind comments. There are multiple ways to set a surface to Adiabatic in Honeybee and it will/should automatically set the sunExposure to NoSun. In my test I can’t reproduce the error and it totally works fine. I will be happy to take a look if you can upload your script here.

Thanks,

Mostapha

setAdiabatic.gh (124 KB)

Thank you very much Mostapha for replying me. I was following the same procedure you are suggesting.

I discovered that I have a delay with ‘LabelZone Surface’ component. In particular it seems that it updates the zone properties after closing and re-opening rhino. Anyway, I will check more on that (perhaps there is cache to reset or something like that).

Again, thanks.

berardo

Ah yes! That was a bug in the ‘LabelZone Surface’ component that I wrote and I am sorry for that. I was trying to save the user time by copying the data of the zones to memory (if the input geometry did not change) since recalling the honeybee zones from the hive can be a lengthy process of several seconds. However, I later realized that this would cause the component to not update if the user made a change to the zones upstream of the component and the input zone geometry did not change. Needless to say, I have since fixed the error and I now recall the honeybee sones each time an input to the LabelZones component changes. So, if you sync with our github by using the “Update Honeybee” component, you should see that the new ‘LabelZone Surface’ component will not give you that delay.

-Chris

Nothing to be sorry for Chris. The plug-in is simply great…

thanks for this message.

-berardo

Mostapha,

I am using the same feature for a single zone analysis and I am assigning adiabatic to all my walls except for one. I see an error which says that I need a newer version of HB to use this component. I recently downloaded HB and I am wondering if this error is due to something else.

Thanks for your help in advance.

Ladan


7-SingleZoneIntegratedDLandEnergy_WithMat_Sched_Adiabatic.gh (697 KB)

This problem is solved when I rebooted my system.

Ladan,

This is probably because you have opened one of older example files and tried to run the newer version afterwards. All you need to do is to disable/enable the honeybee_honeybee component to overwrite honeybee library loaded in memory.

Mostapha