Honeybee Energy Sim Runtime Error

HI guys,

Me again, I swear I’m not trying to piss you off.

So this time after updates I’m getting a runtime error in the ‘Honeybee_Run Energy Simulation Component’.


Runtime error (TypeErrorException): unsupported operand type(s) for +: ‘str’ and 'NoneType’
line 1206, in writeBatchFile, “<string>”
line 2022, in main, “<string>”
line 2040, in script

I’ve trying rebuilding the definition from scratch several times, messed around with permissions but nothing makes a difference. I suppose something change in recent updates because it was working fine in version 0.0.56.



P.S. You guys have better support than any Autodesk product.

energysim.gh (466 KB)

Hi Mauricio,

Having a good day, ah? :slight_smile:

Your file is running just fine at my end.

From the error you wrote and looking at the code i think you are having (again) a permissions issue. Probably you don’t have the proper rights to write at the location HB is trying to do so.

Try to hook a panel with a location you know you have the rights to the WorkingDirectory input.


Its definitely one of those days…

So I’ve tried rebooting the PC but didn’t help. I’m running the program as admin and its still giving me the same error.

Change the dir…same thing.

Its weird because it was working fine this morning. I’ve even tried allowing complete permissions to all users and it doesn’t fix the error.

Is there a way to perform a clean uninstall of honeybee & Ladybug?


It is not HB/LB issue. Fact that your file works for me without changing anything.

But just in case you want to do this, go to the location of the UserObjects of GH and delete all HB and LB. Download from the github the updated version and drop again there.

Weird, anyways.


As you predicted it didn’t help.

I hope a system restore to a previous state will do the trick. I cant explain what changed during the day that would cause this problem.

Thanks for everything.

best wishes,


I would not restore your system. I’m sure the error should be something minor.

Wait a bit, maybe Mostapha or Chris will have another idea what can be the issue here.

Normally i will say to reinsert manually the component(s), but this is working for me.


I agree with Abraham. The issue is that I removed the version 8-1-0 from supported EP versions in the new Honeybee. Well, maybe I shouldn’t. Give me few minutes and I will get this fixed and add a Warning in EP component to let you know about similar issue instead of crashing!




I added version 8-1-0 back and added a warning to Run Energy Simulation component. If you update Honeybee you should have it fixed.

BTW is there any reason that you are still using EP 8-1-0?


I’ve been looking around for E+v8.2 all morning but the site only contains files up to or a link to github for the latest 8.3 version. Where did you get all the 8.2.1–8.2.10 versions?



You can find all the versions on github release pages. Here is 8.2.0 update 1:


And here is the rest:


sweet! thanks