Honeybee materialLib Exception

Leaving this narrative of fixes up here in case someone searches for the keywords, otherwise I fixed what I broke. The definition setup itself works.


Edit 2: Solved. Old version of gencumulativesky.exe did not accept -p parameter and made empty sky.cal file.


Edit: solved run problem, Bee did not download OpenStudioMasterTemplate.idf

Get it here: https://github.com/mostaphaRoudsari/Honeybee/issues/119

Now get empty HDR:

C:\ladybug\prox\imageBasedSimulation>rpict -i -t 10 -vtv -vp 245.129 -226.458 20
0.405 -vd -0.549 0.656 -0.518 -vu -0.332 0.397 0.855 -vh 42.862 -vv 26.991 -v
l 0 -vs 0 -vl 0 -x 800 -y 600 -af prox_RAD_Perspective.amb -ps 8 -pt 0.15 -pj
0.6 -dj 0 -ds 0.5 -dt 0.5 -dc 0.25 -dr 0 -dp 64 -st 0.85 -ab 2 -ad 1024 -as 175
-ar 150 -aa 0.200 -lr 4 -lw 0.050 -av 0 0 0 prox_RAD.oct 1>prox_RAD_Perspectiv
e.unf
rpict: 0 rays, 0.00% after 0.0000 hours
rpict: skybright`c__ladybug_skylib_cumulativeSkies_SINGAPORE_SGP_SINGAPORE_SGP_1
: undefined variable
rpict: 1020 rays, 4.91% after 0.0000 hours


Hi friends,

trying to get a cumulative sky image metric to run and encountered an issue with the image-based metrics component. It throws:

Runtime error (KeyNotFoundException): honeybee_materialLib
Traceback:
** line 768, in main, “<string>”
** line 1442, in script

I guess this is some sort of setup issue on my end, or I messed up the definition? Any help appreciated.

Thanks,

Max


Hi Max.
What’s the status on this one now? I’ll be away for few days but the general recommendation for cases like this is to update your components!
Mostapha

All fixed. I accidentally used an old GenCumulativeSky.exe from the archives that did not accept the -p parameter, and my firewall prevented Honeybee to download the proper one. Digging through the output reports solved it, as well as getting the OS master template manually- that’s what caused the materialLib exception. Enjoy your stay away & hope you won’t check in here :slight_smile: