Honeybee Runtime Error: Win32Exception

Hi everybody,

iam new to honeybee and ladybug! When i try to launch honeybee the honeybee icon in grasshopper is highlighted red and always prompts this error message:

I reinstalled honeybee and ladybug and followed the installation instructions line by line. Nothing changed. So i tried to figure out the problem and found this discussion. I read the messages and tried every possible solution mentioned in this thread, but nothing changed.

I attached an image of the output of the honeybee_honeybee_DEC_08.gh file

Mostapha replied to another user:

"that this might be a permission issue and happening for the same reason. Let’s do this. If you check output of Ladybug_Ladybug component it should tell you where the default folder is set to. It can be C:\Ladybug or C:\Users%USERNAME%\AppData\Roaming\Ladybug. Can you check and see if the folder is already created? If not can you create it and let the Honeybee fly again?

I tried this but honeybee didn’t fly!

Another reason that I can think of is the %USERNAME% on your system. Hopefully it doesn’t have a white space."

Can somebody please help me solving this problem?


I would suggest, for starters, to update to the latest version from github. Your picture shows a VERY old one.

Do that and after that report how is it going …

-A.

I second Abraham’s suggestion. I wonder where did you find this version. The version on food4Rhino is also newer than the one that you have up there. Let us know if updating didn’t solve the issue.