Honeybee Set EP Zone Thresholds...humidity?

if I don’t connect a min/max humidity value to the Honeybee_SetEPZoneThresholds component, I understand that this essentially removes the humidistat from the zone…when I run my model, I get results that make sense…(i.e., zero humidification energy)


when I connect a value of 100 to the maxRH and a value of 0 to the minRH, I would have just assumed this would return the same results…however…humidification energy is present…


any insight as to what is going on behind the scenes?

I am not sure which system you are using. It might have humidity controllers somewhere in system ( might be in cooling coil) that normally are not active, until you have set humidity setpoint in the zone which actives all humidity controllers in the system.

Even though you have set RH from 0-100, but it is still a signal tells HVAC need to start looking at humidity level (it might have some default values), which leads to coiling coil working harder to dehumidify the OA or return air. And for some reason, humidifier thinks RH is too low, it starts humidifying the zone.

These are totally my guess, it might be wrong. To better understand zones condition, I would take a typical summer week, and look at hourly data to compare before and after.

thanks Mingbo! still trying to figure out the root of this cause…I tried to do a ‘text replace’ if the slider MinRH input is 0 and change it to ‘no limit’ following what the default is in the component description (see image below)…


…but I get a “1. Type conversion failed from Text to float” error. @chris/@mostapha, any inputs that work (besides no input at all) that tells E+ not to enable humidification?

@josh.greenfield I think an “empty input” is “no limit”, instead of text input “no limit”.

I got same text/float error when trying to pass an empty input into it…

I adjusted and added in some stream filters and I believe this configuration works…I bet this is what you met by empty input in lieu of what I did as an empty text string.

thanks for your help in getting it to work!

@josh.greenfield right, “filter” is what I typically use.

1 Like