Hvac system not assigned. No changes in HVAC for simulation [solved]

#1

Hello.

I can´t assign data with Honeybee_Assign HVAC System component. Always the warning 1. HVAC system -“X” has not been implemented. I try to assign some basic inputs as heat recovery or COP for cooling and heating with no luck… always same result
Any help here, many thanks.

boxTest.gh (602.6 KB)

#2

@JuanPabloTrujilloLev Thermstat only is just for cooling and heating load calculation. It is not a real HVAC system. If you want to set details of HVAC system, you should select system 1-17.
image

#3

Thank you @minggangyin

In fact I’m doing simple load calculation and I want to use ideal load options but the component never assigns a system. My goal is to see how heat recovery impacts the annual balance but always the results are the same.

#4

@JuanPabloTrujilloLev You should use system 0.Ideal Air loads instead of -1.Thermstat Only.

1 Like
#5

Yes, that´s the type I plan to use if the component works ! My problems in the gh file is that the component not assigns the system and no changes in loads with heat recovery and I think should be difference in a climate like New Zealand !
Any Idea?

#6

@JuanPabloTrujilloLev After checked the file,I found a bug within it.
You should replace EnergyPlus with OpenStudio


Here is the comparison of two results using Openstudio.

boxTest_debug 07-26.gh (627.2 KB)

#7

Thanks a lot for this @minggangyin, your debuged file was very helpful, whit that I can see that one of the problems was the geometry of the zones the model I´m working (convex surfaces to be specific). Once that fixed I just have to add a new assign hvac system components to the canvas and goes ok.

However there is an issue that not worked in my working model but in the simple box geometry example goes well. For my working model the simulation doesn´t start with the error “Calculation would require division by zero” when I assign some plenums zones. At the end I can´t assing plenums. But for the simple boxes goes well.
Any idea?

Here my working model.
Lomond House NZ vForum.gh (802.3 KB)

Maybe the issues come from the complex geometry of plenums?

#8

@JuanPabloTrujilloLev This is another question. You should create a new issue for it.