Index Out Of Range radiance error (truncate octree failure)

This is kind of pissing me off. The file was working properly a few minutes ago, with wrong results due to bad geometry.

After taking out the invalid brep, I managed to assign materials and preview all of my geometry properly. Then I just re-run the simulation and I get this index out of range error.

Radiance mailing lists didn’t help a lot, most mentioned material assignment issues or placing some geometry outside your scene in order to expand the bounding box.

I checked the materials file all seems ok. I vaguely remember seeing it before but can’t recall how I solved it. I tried taking off the ground plane, and using the hbzone with standard radiance materials, nothing changed. Components are also updated to the last github.Any ideas why this is happening?

Thanks in advance.

Kind regards,

Theodore. (594 KB)

The issue is undefined modifier “Air_Wall”

You need to define Air_Wall construction for Radiance model. Honeybee doesn’t have a default construction for Air_Wall for Radiance (I agree that it should!).


Oh, I see. I figured that by not exporting air walls in the run daylight component that wouldn’t be needed. Also, somehow this damned definition worked before. Guessing it worked due to my previous bad geometry.

Is there a reference as to which properties I should assign to my air wall materials? I’ll look around as well.

Thanks Mostapha!

Well if they are really air-walls then you either want to set exportAirWalls_ to False not to have them in your daylight model or assign Glass with 100% transmittance. In my opinion, the first one is the smart approach.


Well I was doing just that but the error was still insisting.

For now I decided to just exclude the surfaces since they are supposed to be doors that will be opened most of the time (maybe silly decision by me to be set airwalls). The simulation is running. I will try and test the true option and assign some material properties and see if it runs.



A few important notes about the air wall surface type:

  1. To ensure a correctly-created file, Air walls should only be used to signify interior partitions that are not really there where you want to use both an air wall construction and to mix the air in between zones of an energy simulation. Here, you are using them for an exterior surface and this causes both the Radiance simulations and EnergyPlus simulations to fail. If you want an exterior surface that lets through light in the radiance simulation and/or air in the thermal simulation, you should use a window instead of an air wall.

  2. Your HBZone is not forming a closed volume and, accordingly, it would not work in an energy simulation. If your intention is only to use this in a Radiance model, why not just make everything HBSurfaces instead of trying to bring it all into one zone?