Ironbug latest version installation question

Hi

I am currently struggling with getting HB+LB functional for a simple modelling task that is still not working - but I may have identified an underlying cause: When Grasshopper is loading I get the following pop-up error message: "Cannot find OpenStudio (2.8 or newer installed). This happens when the grey bar at the bottom of the Grasshopper loading splash screen says “Loading remote assembly Ironbug Grasshopper”.

NOTE: open Studio 2.8 is installed in the default location: (copy address as text) “C:\openstudio-2.8.0”

I realise that this may be the cause of the error that I cannot get rid of when trying to use the HB_Export to open Studio component:

"Current document units is in Millimeters
Conversion to Meters will be applied = 0.001
Current working directory is set to: c:\ladybug\unnamed\OpenStudio
Runtime error (EntryPointNotFoundException): Unable to find an entry point named ‘CSharp_OpenStudio_new_Model__SWIG_0’ in DLL ‘openstudio_model_csharp.dll’.

Traceback:
line 5392, in main, “”
line 5668, in script:"

Note 2: As far as I am aware, the latest version of Ironbug has been installed.

M

Hi @MichaelDonn
Could you please double check this Honeybee_honeybee in your script, and see if it can find the openstudio2.8?

-Mingbo

My apologies. I should have said, that when I ‘let the bugs fly’ all seemed to be OK. It was the odd behaviour of the message while the Grasshopper splash screen was playing that I found unusual.

M

Hi @MichaelDonn, you seems have everything all set, it should be fine. But I cannot really tell what’s causing it.

The first error message "Cannot find OpenStudio (2.8 or newer installed)" is because Ironbug cannot find OpenStudio 2.5 or 2.8 at “C:\openstudio-2.x.0” folder, but as you said, you have 2.8 installed already.
By any chance, you might also have 2.8 installed in “C:\Program Files” or anywhere else? Have you tried to remove all other versions except 2.5 or 2.8, just keep one version on your pc?

The second error Runtime error (EntryPointNotFoundException): Unable to find an entry point named ‘CSharp_OpenStudio_new_Model__SWIG_0’ in DLL ‘openstudio_model_csharp.dll’. is mostly current grasshopper loaded two different version of openstudio, you might have installed the openstudio 2.8 while Rhino/Grasshopper is open, have you tried to restart a new instance of rhino?

Hi @MingboPeng

Thanks for the suggestions. I have searched for “openStudio” both on the C\ drive and in the “Apps” section of the Win10 settings. In each case, there is only one copy. I have also before writing my query uninstalled and reinstalled OpenStudio once as I suspected some form of corrupt installation.

m

Hi @MichaelDonn

Could you please double check this folder C:\openstudio-2.8.0\CSharp\openstudio ? could you find OpenStudio.dll file in it?

By any chance that you could test it on another computer?

Thanks,
Mingbo

Not able to trial on another Windows computer at present, sorry.

Hi

Works seamlessly on my home computer with what is apparently the same version of everything.

I have tried reinstalling
OpenStudio
EnergyPlus
Latest version of IronBug

To no avail…

Might there be an issue to do with not having the same right at work as at home in stalling and running software

M

Hi @MichaelDonn
Could you please download this gh file and open it on your computer, and take a screenshot of the outputs? CheckOpenStudioVersionLocation.gh (8.5 KB)

This file basically checks if any openstuio library has been loaded, and also trying to find the location of openstudio.dll.

I am now, officially, very puzzled.

Sorry to be a bother.

M

I am also confused, definitely want to know what happened.
Could you please use this new gh file to check again, it might provide you more info.
CheckOpenStudioVersionLocation2.gh (3.4 KB)

Clearly more information - your check is finding OpenStudio 2.7 which I have removed… I have uninstalled, and re-installed OpenStudio just now (the copy that works at home). Problem persists.

M

@MichaelDonn This definitely provides us a direction to look into.

There might be two places related to this:

  1. By any chance that you have openstudio old libraries (OpenStudio.dll, openstudio_csharp.dll,etc.) copied to C:\Ironbug folder. If yes, please remove them, otherwise, Ironbug will only load openstudio library from this folder.

image

  1. If the first issue is not the case, could you please go to C:\openstudio-2.8.0\CSharp\openstudio and right click the OpenStudio.dll for properties, and check if this file is 2.8 under Details tab.

Hi

Having checked these files in the C:\OpenStudio directory, I forgot to delete them from the C:\ironbug directory at work.

Please accept my apologies for bothering you with this when the answer seems to have been so obvious.

All apparently working now.

M

No at all, I am glad we finally pinpointed the issue.