Issue related to the Honeybee_Visualize Annual Comfort Result (VisualizeComfort)

Hello all.

I have been following the wonderful tutorials by Chris Mackey, however on I am stuck on the late part of the video 8 - “Honeybee Energy Modeling - Importing and Visualizing Surface Level Result”.

Its about making radiant temperature map, but it gives some errors such as:

  1. The length of data in the comfResultsMTX does not matech the number of faces in the viewFactorMesh.

  2. Solution exception:index out of range: -2

Its just simple box building that simulation itself doesn’t take long, and I’ve updated my HB and LB components and everything seems ok. But still having the problem.

Since the components have major and minor changes I’ve managed to connect _comfResultsMtx to the read Comfort result component to do the simulation, however it has some other issues as well.

The components error message says

  1. Failed to parse the result file. The csv file might not have existed when connected or the simulation did not run correctly.Try reconnecting the _resultfileAddress to this component or re-running your simulation.

So the question is how to achieve radiant temperature map? and could it be done in specific analysis period instead of annual cycle?

Best Regards.
Awkweird.

Honeybee issue.gh (558 KB)

Awkweird,

Attached a working version.

See group red for what was unnecessary.The HB_readComfortResult component requires a file path to work and not a recipe. Usefull if you don’t want to rerun the whole thing.

See group white for what was missing.

Somehow , even though you said the file was updated, it wasn’t fully. I updated again. Some of the components required a re-insertion since the number of items changed. The components are being revised those days, i assume.

-A.

Honeybeeissue_AY.gh (577 KB)

Thank you Abraham for your quick answer. It was helpful to understand about HB_readComforResult components.
And now it works perfectly on the small building masses. However, increasing the number of breps cause some issues on HB_Indoor View Factor components.

The error message: 1. Solution exception:need more than 0 values to unpack

In this case what could be the proper solution? I am wondering if my building mass is too much to handle. It consists 90 breps and 5 floor office building.

I am uploading the file with disabled most of the components inside to load easily.

And one more thing to ask. If update the HB & LB components using the LB_update and HB_update, do I have to re-insert everything again or some certain components have to be drag & dropped?

Best Regards.
Awkweird

Honeybee_issue_2015_05_01.gh (772 KB)

Can’t be helpful here regarding the error you are receving.

As for the update the HB/LB update components most of the times take good care of the process and you DON’T need to reinsert anything. That’s why they are for. But sometimes some components change, for instance, the number of input or output items. Those you need to reinsert/reconnect so they work properly.

-A.

awkweird,

I cannot replicate your error with the view factor component.

Can you confirm that the attached file is not running ok for you on your system (note that is will take a few minutes to run when you open it)?

-Chris

Honeybee_issue_2015_05_01CWM.gh (776 KB)

Thank you for your reply.

Unfortunately It doesn’t work work. Gives the same error message.

Maybe I should try with less breps.


Awkweird.

Awkweird,

Sorry for getting back so late and I think that I may have identified the problem. What service release (SR) of Rhino are you using? (Go to the Rhino window’s Help > About Rhinoceros and check the number that comes after “Version 5 SR” in the window that pops up). It seems that the Rhinocommon “Split Brep” function is not working on your system and this is one.

To provide a temporary fix, I have put in an extra check that should correct the problem in most cases (the worst case now should be that you get some parts of a mesh that are showing you outdoor conditions). Please let me know if the attached file works. As you can see, it is fine on my system and I internalized a mesh in the GH file with what the final comfort map should look like.

-Chris

Honeybee_issue_2015_05_01CWM2.gh (826 KB)

Hello Mr.Chris

Haven’t noticed that you replied on this issue and thank you for your generous guidance.
it seems like working on your machine. Unfortunately it still doesn’t work with the file you just uploaded.

My rhino version is: 5 SR11 64-bit
(5.11.50226.17195, 2/26/2015)

Even the simplified building mass (3 floors building with 15 rectangular simple breps) doesn’t work either.

Should i upgrade Rhino or grasshopper?

Awkweird,

I noticed from your picture that the HB_IndoorViewFactor doesn’t have connected the HB_Zones. Can this be the problem? See that the readMe output of this component is empty.

-A.

Thank you Mr.Yerioro, you just pointed out what I should’ve done on Mr.Chris’s fixed file.

It works perfect now. I have to be careful on every component and connections next time.

Have a great weekend!


AWESOME!

Glad to hear that we worked this one out. Thank you both, Abraham and awkweird.

-Chris