LB/HB moved to the wrong directory, E+ simulation won't run

I haven’t used LB/HB for a few weeks so it’s quite a surprise for me to find that it wasn’t working the way I expected.

‘Run Energy Simulation’ in particular won’t run.

I think the problem has to do with the LB/HB components being placed in the wrong directory. If I remember correctly, it should be placed in the same directory sa Special Folders>Components, instead it was randomly transferred (I have no idea why) to Special Folders>User Objects.

I’ve already experienced this problem with my laptop (which I eventually reformatted to fix a bunch of problems, including this).

I’ve tried completely removing LB/HB then reinstalling it, it still places the components in the Special Folders>User Objects folder. (Also tried reinstalling Rhino, GH from scratch to no avail).

Pin, i would suggest sending the output of the out item of the component.
I don’t believe the problem is related to a “bad location of files”.

I’ve tried this with a lot of my files which were working fine previously. None of them would let E+ run.

Hmmm …

Can you upload one of those files? All of them complain about the missing mandatory inputs?

I am suspicious about the HBZones input. Can you also check they are well defined.

I’m saying that because the component chack says:

if _writeIdf == True and _epwFile and _HBZones and _HBZones[0]!=None:

print “At least one of the mandatory inputs in missing.”

So i see the writeIDF and epwFile are ok, so the one left is the zones.


That’s weird… I have no idea what happened but it’s fine now…

Thanks for the assistance.