Leaking Light to inside walls

Dear all,

I am checking illuminance on the floor by honeybee(radiance).

When I look the result, there is leaking light inside of the wall.

This model is completely closed Brep. So there should be no light inside of the wall.

Any ideas?


Can You post your geometry and GH definition. Or an image

Also check your Normals they should be pointing outwards

Ryosuke,

I am having some trouble understanding what exactly your issue is. From what I can tell, i looks like you are running an image-based simulation without a ceiling to your room. My guess is that you probably want to run a grid-based simulation with a ceiling.

-Chris

Hi Ryosuke, What are the radiance parameters in your scene? If you are not sure how to set the parameters use Honeybee’s RadiancePar component and set the quality to medium or high.

Thank you for your reply. This is the file.

150716_test.gh (428 KB)
150717_test.3dm (986 KB)

Hi Ryoshuke,

I believe I’ve encountered light leaking in some simulationd due to Rhino tolerance. Sometimes tolerance settings were not correct and my joined surfaces were not considered joined. You can try playing around with that.

The other reasons were pretty much covered by Mostapha and Chris. Usually you want AB (the ambient bounces) to be greater or equal to 5 no matter the quality, as it is one of the most important variables for a dependable simulation. Of course it depends on the nature of your geometry but 5 min. is a safe bet.

Btw, I couldn’t see which geometry you are plugging where as one pipeline was empty in the file you posted when I opened it. Could it be that you forgot a surface?

Another point is the unit range you are using. Is that really 10 lux as maximum in your picture? Because in that case it makes sense for everything to be yellow (inside and outside) as you most likely will have more than 10 lux everywhere.

P.S.: Selecting medium/high quality sets all the variables for you, no need for additional sliders. In your case you are actually overwriting the quality settings.

Kind regards,

Theodore.

Hi Theodoros Galanos,

Thanks! I gonna play with these tips form you.

I uploaded modified file on this post.

150716_test.gh (428 KB)
150721_test.3dm (807 KB)

>Another point is the unit range you are using. Is that really 10 lux as maximum in your picture? >Because in that case it makes sense for everything to be yellow (inside and outside) as you >most likely will have more than 10 lux everywhere.

Yes, it was 10 lux as maximum. If no light is inside wall, the wall should be displayed as black.

but the wall is quite colorful in the picture I showed. so there was leaking light.

any ideas?

Ryosuke,

I have been playing around with the file that you uploaded but I cannot figure out what you want us to see in it. If you are using an image-base simulation and you are slicing your model open with a section, you are going to get light coming through the slice.

If you use a grid-based simulation like the attached file, you see that you get 0 illuminance inside a completely sealed box.

-Chris

150716_test_CWM.gh (439 KB)

I know I can get similar image with grid based simulation. But, I would like to use image based simulation with clipping plane option.

I found a hint.
Can we do the same way like this site?
http://climate-based-daylighting.com/doku.php?id=resources%3Aradian

You can use sectionPlane input in Honeybee to achieve that. As you can see the room is pretty dark! Attached is an example.

planeClipRadiance.gh (440 KB)

thank you! I used this method but leaking was happens.

Pay attention that for the section plane to work the view needs to be perpendicular to the plane.

You can do it manually in the perspective view. Just view from the top as much as you can.

Top view doesn’t work for that. You need some perspective distortion.

-A.