Length of result not equal


I am sure the error is not a new topic as it has been discussed several times as I found several posts in the forum.

However, I have tried all the solutions mentioned which none of them work for my case.

Would anyone give me some clues on it?

I have tried (1) flatten the result, (2)not setting any north, (3) setting the unit to meter

Is there sth that I missed?


if you’re plotting sDA you’ll get this error

even when I plot output from run radiance, I also get this error

can you please share the simple file

try a mesh join before putting the mesh into here:


Tried join meshes, no luck

SDA_Sent.gh (850.8 KB)

hi @Ivanna Can you try converting your rhino units to meter and rerun the study.

the model is already in meter.

please follow this example file 04_annual_daylight_gridbased.gh (79.5 KB)

Thanks, the sample file helps.

My findings are the sDA is a % for the mesh which can’t be mapped on the mesh.

Mapping the DA with no errors.

sDA is a single results for the area selected (spatial), hence it can’t be mapped.