Little error in the RadPar component (LBT 1.2.0)

Dear @mostapha,

I hate to bother you, but I think I found a small “error” in the RadPar component of the new LBT 1.2.0.
I want to manually edit the values of the radiance parameters, but I see there is a problem with the -as parameter.
As you can see from the screen, it is the only value that would require an underline ( as_ ), but even inserting the underline I still have an error.


I tried to delete the underline directly from the component, but still it doesn’t recognize the parameter.

No problem with all the other parameters instead.

Thanks and best regards

1 Like

Thanks for reporting, @LiamRuvio . This is, indeed a bug! And an odd one at that.

It seems like it’s related to an inconsistency between Rhino’s IronPython interpreter and the standard Python interpreter. In any event, I just pushed a fix:

… and you should be able to get it with the “LB Versioner” within an hour or so.

Thanks dear Chris, unfortunately I have tried several times to update via LB Versioner (even with Restart Rhino) but the RadPar component remains at version 1.2.0.


This particular fix was actually in the core libraries so component version 1.2.0 is fine as long as you ran the “LB Versioner”. But updating your installed version of the plugin doesn’t change the version numbers of the components on the canvas of a particular Grasshopper file. For that, you need to run the “LB Sync Grasshopper File” component.