Multiple CPU causing errors (Radiance)

Hi!

I keep experiencing a problem that disappears after I turn off multiple CPU´s. A DF calculation with simple geometry. It seems as if the analysis points that get routed to the different cores somehow acquire different settings/are calculated differently. Appears at random “rows” of points, sometimes it all works fine, so I need to do a series for the error to show. See images below.

In the Ladybug fly run the VT of the window changes.

It’s taken me a day and a half to track this error down. Phew.

I get the same error on two different comps.

What is causing this? Does anyone get the same error? Images below created with RADquality set to 2, and 7 cores. Fiddling with Radsettings dont help, I think, except error goes away with very low ab.

Stripes forum question.gh (635 KB)

Ooh, I forgot to internalize geometry. Here is the new def.

Stripes forum question internalized.gh (573 KB)

I posted this on github instead.

https://github.com/mostaphaRoudsari/honeybee/issues/647

Ran your definition, didn’t get the error you mentioned though. The results I got more or less seems to make sense (not a daylight expert).

neuPNG.rar (117 KB)

Ludvig,

I haven’t gotten the chance to check your definition yet but I can say that Honeybee runs simulations in parallel in a fairly “hacky” way. It simply takes some of the points and runs a simulation on one core and takes another set of points and runs another simulation on another core. Then honeybee tries to take all of those separate simulation results and stitches them back together into one set of results.

It seems that this error is the result of something going wrong in the last part (stitching the results together in the right order). I’ll try to take a look at it at some point. But for now, you might try using the daylight lookup folder and see sorry the result files to get them in the right order and then import them.

-Chris

Ok, cool, good advice should I need the speed of multiple cpu´s. For now I´m very happy using a single core setup though.