Not getting radiation results

Hi,

I’m trying to do a radiation/insolation analysis on a project. I had set up a ladybug definition at an earlier workplace and it worked just fine - I got good results that I was able to compare against other programs.

When I try to replicate the definition at my new workplace I get no results (rather I get only zero values). Since this is a definition thats worked in the past, I think it must be either an issue with the computer, or my ladybug installation. I’ve checked normals and all the basic steps.

Anyone experienced something similar? How do I get around this?

Any insight is much appreciated. I’m attaching my grasshopper file and a screenshot.

Thanks

Vikram.


Radiation_Def.gh (33.5 KB)

Vikram,

You forgot to internalise the geometry, but the issue is not in the RadiationAnalysis but before that. Probably in the GenCumulativeSky component. Check weather you get any output from it or from the SelectSkyMtx component.

The issue has been discussed previously a few times (as i recall). You can see one of those here.

-A.

Thanks Abraham,

Still doesn’t solve the issue. Here’s an example file with the internalized geometry I downloaded off this forum, that doesn’t really work on my computer.

-Vikram


quick example radiation analysis.gh (391 KB)

I think the problem might be in the select sky component. For some reason it shows everything as zero coming out of this.


Hi Vikram. What happens if you remove the analysis period? I wonder if the sky is generated correctly. Can you check readMe output on genCumulativeSky component.

Hi Mostapha,

I tried that earlier too, with no result. Here’s a screengrab and the definition.

Thanks

Vikram

Radiation_Def.gh (33.5 KB)

Hi Vikram, Sorry that I dropped the ball on this one. The sky is not generated correctly in your case. Here is a similar discussion. Can you install radiance in C:\radiance try the suggested solution?

Yes! That worked!

Whew! I had radiance installed in the C:\radiance folder. What made it work this time was the working directory addition.

Thanks Mostapha!