OpenStudio error when generating outdoor microclimate map


I’m looking for some guidance on a honeybee outdoor microclimate map simulation I have been trying to run for a number of days without success.

When attempting to run the ‘export to openstudio’ component, I receive the following error: “1. Solution exception:E:\Git\OS1\openstudiocore\src\model\PlanarSurface.cpp@643 : Cannot create a surface with vertices [[-81.7914, 117.598, 6.37679], [-81.0082, 116.14, 6.37679]]”.

Has anyone come across this error before? I’m unable to diagnose it from previous topic threads. Attached is a copy of the geometry and GH file.

I have tried various measures to resolve this error without success. Any help that anyone can provide would be hugely appreciated.

James (9.7 MB)

Please set units in rhino to meters.

Hi, I have checked and units are set to meters

I checked you file, your geometry needs a lot of simplifying.

Are you referring to the context/surrounding buildings? I had suspected this, and ran the simulation without context included, but the same error is returned in the exporttoopenstudio component when this is done.

Yeah. If I disconnect the context geometries, the simulation works. It only gives warning for shadowing due to non-convex surfaces. Which can be easily avoided by choosing 0 in solar distribution option on energy simulation parameter.

@jwoodall ,
OpenStudio is giving you an error because it’s trying to create a context surface from 2 vertices. Perhaps you have some invalid Rhino geometries in there and you should clean-up/simplify the context as @devang suggests.

@chris @devang Thanks both for the suggestions. I will try cleaning the context and stick to simpler forms in the future.

Hi @devang & @chris, I’ve been trying to run a microclimate map simulation with a simplified masterplan geometry but the problems with OpenStudio interpreting context remains. This error doesn’t show when the context geometry is omitted, but I’m unsure I can simplify this context any further.

Please could you help to troubleshoot this issue, and let me know if you’re able to suggest any methods to overcome it? Current GH file attached. Outdoor_Thermal_Comfort (823.2 KB)

Thanks in advance.

Hi @jwoodall ,

I had a quick look at your file. I deleted various blocks that are not in close relation/proximity with your analysis surface and it appears that the simulation starts - well, no immediate orange component. I didn’t wait to finish though, cause it would have taken a while for such a model. Have a try with less blocks and see if this can fix your issue.

From past experience with E+ through Design Builder Software, I remember that sometimes E+ doesn’t really like extensive and complicated external solar/shading calculations which are not in close proximity with the analysis geometries.


i agree with @OlgaT’s solution here. I would only use buildings that abut the street as shading context. The heat from other buildings will not directly affect the comfort simulation. One way to account for those remaining buildings would be to use Dragonfly to model UHI.

Hi all,
I’m getting Openstudio error eventough I have very simple geometries.I spent so much time to work this out and I really want to have some outcome. Maybe it’s something else.
If someone can see what’s wrong with this file, I would really appreciate. (817.2 KB)