OpenStudio version 3 - the beta


Just loaded my copy of Rhino at home. Unfortunately, Ironbug does not recognise the latest version of OpenStudio recently installed. Should I re-install the 2.9 I just uninstalled?


@MichaelDonn As I know, ironbug supported OpenStudio 2.X Verson, not supported OpenStudio 3.0 Version.

Indeed - in fact, Honeybee threw an error as well!

I have reinstalled OS 2.9.1 alongside the beta.

I was keen on the beta as it solved an integration with the latest version of Sketchup


1 Like

Hi @MichaelDonn ,

I think you installed the OpenStudio Application, which is installed to “C:\openstudioapplication-1.0.0-pre1” by default, but all ladybug tools are still looking for OpenStudio under “C:\openstudio-*” folder.

If you really want to use the only one version on your computer, you can install OpenStudio Application to

"C:\openstudio-3.0.0" instead of “C:\openstudioapplication-1.0.0-pre1”

1 Like

Genius! - I will give it a go.



Thanks. Tried that. Did not work. The openstudio.dll in the Csharp\openstudio folder was not there, so Letting the bug fly generated an error…

Nice idea though.

Reverted to 2.9.1 for now


I should also say that a lot of changes have been made to OpenStudio’s SDK with version 3.0 and it will take us some time to make the honeybee components compatible with it. But, so far, it looks do-able.

Understood. It was worth a try as the plugin working with SketchUp made other parts of our teaching workflows viable.

Thanks also for following up the Honeybeeplus questions which are being solved slowly (with the ambition of packaging UDI / DA calculation via HUI for our 200-250 students in our July-October classes)

Hope you and your loved ones are safe and well.

kia kaha