Overflow exception

Hi everyone,

I am having an error on the most simple simulation ever, and I don’t understand what is causing it. It is not the geometry, I tested already with just a box.

The OSM file is not created flagging this error:

Current document units is in Meters
Conversion to Meters will be applied = 1.000
Current working directory is set to: d:\honeybee\Test1\Rooftop_noSH\OpenStudio
Can’t find ddy file next to the EPW.
Extreme values from the weather file design will be used instead.
Runtime error (OverflowException): math range error
Traceback:
line 6420, in isRectangle, “”
line 5657, in evaluateZones, “”
line 5432, in main, “”
line 5651, in script
line 6248, in extractMeshPts, “”
line 6304, in extractPoints, “”
line 5955, in checkZoneSurface, “”

Could you please give it a look and see what I have missed? because I am going crazy to find something.
181030_Forum.gh (701.9 KB)

Thanks,
Julia

@JuliaT,
Can the cupula be the cause?
-A.

Sadly no, that was my first guess and I tested without it and without windows, and I got the same errors…

OK.
Checked more thoroughly. There are 2 problems, each having it’s own severe errors:

  1. Having windows in adiabatic surfaces.
  2. The cupola.

Each of them is making trouble. So what i did to make it run is to disable the cupola (adding the full floor surface), define the walls as outdoors. With this conditions it runs.
I’m not sure what can be done about the cupula. Maybe to simplify its geometry. In any case it is not previewed under any of the output items of the decomposeByType component.
As for the windows i believe here we have a bug. Probably all the checkings in the OS component don’t take into account the possibility of having just one thermal zone with adiabatic walls with internal windows on them.
@chris what do you think on this?
Attached the file working with the acknowledge is not what you intended.
-A.
181030_Forum_AY.gh (990.5 KB)