Problem with construct Location

Hi everybody,

I am doing some tests with ladybug but I am experiencing some problems with the construct Location component, it looks like it’s just not working, what could be the problem?

Please see the attachment

thank you in advance for your answers;


Can be that you didn’t let the Ladybug fly?

Though i tried without it and it works for me …


Yes I actually forgot to let it fly…I fixed it but still doesn’t work…

The outputs of your components seems to be changed from what it should be. It should be location and not out. Replace the current component with a new one from Ladybug tab.

this is what I get by default from the Ladybug tab…

thank you


Hi Marco. You are using an old version of GHPython. Update to the latest version (GHPython and it will get all fixed. -Mostapha


thank you but unfortunately it didn’t work, now I cannot even place the component in the canvas…

Ok I fixed it, it was just about unlocking the new python.gha

Thanks a lot for you help


Hi M

I got the same problem like you experienced. Could you tell me how can I unblock the GHpyhton, Does it mean just use this the latest version to replace it? Thanks!!

Hi eblis,

When you paste the ghpython in the component folder right click on the file and open the properties , there you should find thr button “unlock”.