Problem with installing Ladybug tool, Rhino crashes! SOLVED

Last update 19.4.17

If you faced the same problem, try to delete IronPython if you have it installed on your computer. It worked for me.

UPDATE 19.4.17

I upgraded Grasshopper to 0.9.0076 and I went through the steps again. I figured out that it crashes when I add GHpython to Grasshopper. Older versions of GHpython gave the same results.

Any ideas?

Thanks :slight_smile:

Original discussion 18.4.17

Hi all,

I installed Ladybug as it is explained in this link ( http://james-ramsden.com/installing-honeybee-for-grasshopper/ ) but when I use any component, from Ladybug or Honeybee tool, Rhino crashes!

I have Win10-64 bit, Rhino 5, GH 0.9.0069. and I installed:
1. GHPaython that is compatible with GH copy I have (0.5.99 Coding location - For
Grasshopper 0.9.0061) 2017-Feb-13. I also made sure to unblock the file.
2. Daysim to this destination. C:/DAYSIM/
3. This copy of Radiance, (radiance-5.0.a.12-win64.exe) to this
destination C:/RADIANCE
4. Latest release of EnergyPlus (8.7.0)

Can I get some help?

Thanks in advanced. :slight_smile:

Best,

Hussein Abohamida.


Hi,

Did you go through this?

Hi Devang,

It seems like the other instructions I went through. But I will try it anyway maybe different copies might work.

However, I can’t use the (Remove) file because Rhino crashes every time I drag it onto the canvas.

Thank you :slight_smile:

Hi,

I figured out that it crashes when I add GHpaython, do you have any idea why, or how it could be fixed?

Thanks.

Hi,

Do you have the same GhPython version mentioned in the instructions?

Yes I do. But it turns out that the problem is in the IronPython. I deleted it and now it is working as it should.

Thanks a lot for help :slight_smile:

Glad you figured it out.