Problem with RoomEnergyResult

I have a problem with extracting results from the SQL files. the simulation runs fine but when I SQL result file to connect RoomEnergyResult I face with such error “1. Solution exception:index out of range: 5” . but I can extract such title with ReadTable component.

I see this when want to extract the comforting result with the RoomComfortResult .

any suggestion to resolve this to simplify the process?

Can you upload a minimal sample file that can recreate the issue, @ehsan.anvary ? Or can you give us the full traceback that you’ll see if you open the component source code and run it?

It looks like your simulation has run fine but there’s something unexpected about the way the results are formatted in the SQLite file.

Here I upload a simplified version of my file that still has such an error.

75sqm optimization (654.4 KB)

Hey @ehsan.anvary ,

This is a bug and thanks for reporting it. The problem resulted from using the Annual option for the reporting frequency:

For an immediate workaround, you can use the Monthly option for reporting frequency and then sum the values in the resulting data collections to get the annual value. I also just pushed a fix to the development version of the plugin, which you’ll be able to get with the LB Versioner in an hour or so:

I appreciate you reporting the issue but I was almost unable to fix it since it was a difficult to recreate the issue from your file. You have a bunch of external dependencies on components that had to be downloaded:

You also didn’t internalize the Geometry in the Grasshopper file (so I needed a non-existent Rhino file). It’s also far from a minimal file that was needed to recreate the issue. I was looking for something like this, which is all that was needed to find the issue: (52.5 KB)

Please keep this in mind going forward and thanks again for reporting the bug!

Thank you, Chris,
I set to Annual for faster simulation but by changing it to monthly it’s not so different and it’s working for me now.