Radiation Analysis

Hello,

I am trying to run a solar radiation analysis. I downloaded the script from github and also rewrote the script several times. The result does not offer a range it just turns blue. I have tried changing the test geometry as well as the weather file and the result remains the same. I have attached a copy of the grasshopper script as well as an image of what I am getting. Any guidance I would be greatly appreciated!

Thank you!



Whoops forgot to attach the grasshopper file

Radiation_Analysis.gh (402 KB)

Melissa,

I’m not able to check the file now but it seems like you may be closing out of the command prompt window that is running the radiation simulation. Try setting useOldResult to False on the GenCumSky component and make sure to let the command prompt window run.

-Chris

Hi Chris,

Thank you for your quick reply.

I tried setting useOldResult to false but I continue to get the same result. I am not sure what the issue is. Do you have any other idea what this could be?

Also just wanted to say thank you for all the great tutorials you made on youtube with the exception of the radiation one (per the issue I am having ) they have all been amazing! I am learning tons!

Melissa

Melissa,

This works fine on my machine, I’ve seen this issue before and my guess is that the workingDir_ input on genCumulativeSkyMtx component is my default incorrect. Try changing it to C:\Radiance\bin

let us know how you go.

Hi Anton,

Thanks for your reply. Quick follow up, when you say “my default incorrect” what do you mean? and do you mean that I should transfer the genCumulativeSkyMtx component to C:\Radiance\bin?

Thanks again!

Melissa

Hi Melissa,

Sorry for the unclear reply, I meant try this:

If that doesn’t work, I can chat with you on gchat it would be good to get this worked out.

my email is ajszilasi@gmail.com

Ahhh GASP!!! you are a genius!!! That worked!!! Thank you so much! I been battling with this issue for a while . I attached an image so you can see that is worked.

Thanks again for all your help! I really appreciate it.


Melissia,

You’re welcome and sorry for not helping you out sooner there is something fishy going on here and I didnt have enough time to look at the code and work out whats going wrong, hopefully everyone can now see it here for future reference.

Not to worry. I am just happy that it is working now.

Thanks again!

This should be fixed now. Turns out in the new version of Radiance, gendaymtx has a .dll dependency that needs to be copied to the folder. Anton, thank you for the suggestion for the temporary fix.