Run It All


I was trying to run the Run It All component. Based on the image that I have attached, can anyone tell me what might be the problem. Mostapha, I copied this component from the file you sent us (I couldn’t even find the component myself). If I click it, it seems to run multiple runs and saves multiple folders, but I cannot get them to read.

Appreciate it!


Hi Saurabh,

Maybe attach your file too, and somebody acan help you with that, but till then I think just use BRUTE FORCE component from the TT Toolbox , it makes the same



Thanks Peter for letting me know about the BRUTE FORCE component.

I have attached my files here too if anyone knows what the problem is.



Parametric (456 KB)
Parametric Shading.3dm (55 KB)

Hi Saurabh,

The warnings are fine. What do you mean by you “cannot get them to read”? You mean you can’t find the folders? All this component does is animating the sliders, and as Peter suggested BruteForce component does the same.



I was having problems reading the folders I thought it might have been the RunItAll component in the first place. But I figured that out. Its working now. Thanks!



I am facing the same problem as you did exact same error, how did you solved it? I know you solved like one year ago, perhaps you remember.