Running errors when aBSDF is used

Dear all,

I tried to use aBSDF modifier, but simulations (DGP and annual daylight) encounter errors.

The xml file works well with BSDF modifier, but not aBSDF modifier in Honeybee-Radiance.

Has anyone tried aBSDF modifier? Any help or suggestion is appreciated! :slight_smile:

Hi @SichenLu,

Can you provide more information on the errors you encounter? Any error messages?

Are you able to share your files so I can try to recreate the issue on my end?

Hi @mikkel ,

Thank you for your prompt reply!

The error messages are attached below:

Here is a screenshot of aBSDF modifier :

If I switch aBSDF to BSDF, the simulations run without errors.

You could access xml file and the gh file through the link below (I could not upload xml here due to its size):

Thank you,

Hi @SichenLu,

Are you able to share the log file in your simulation folder?


Hi @mikkel,

I just send a direct message about the log file.


Just to mark this as solved. The issue was that for aBSDF modifiers the xml file was not copied to the relative project folder model\bsdf. Instead it was copied to the default folder: C:\Users\[USERNAME]\simulation\BSDF, which causes problems in Radiance if the username has a whitespace character.

Thanks for reporting the issue, @SichenLu.

1 Like