[solved] got "You should first let the Ladybug fly…" warning

I got this warning when opening a gh file working fine previously, and it doesn’t go away even if I updated LB&HB and dragged both of them again into GH.

Any advice on solving this problem without replacing all the components with this warning again and again?


You should send the KB_LB to the back (ctrl+B) and then disable/enable it (ctrl+E twice). Then disable/enable the component(s) that are complaining.


Thank you, Abraham!

Disable/enable the component solve the problem.

Thanks for the good response, Abraham. To clarify, hitting (ctrl+B) sends whatever components that are selected to the back of the canvass so that GH will read those components first when it opens (or re-computes) the file. You want LB_LB and HB_HB to be read before any other components on the canvass since these components contain all of the libraries and functions that the other components use. When you drop a new LB_LB or HB_HB onto a canvass, it puts the components on the front so you have to select them and hit (ctrl+B) to ensure that everything works correctly in the future.


Very helpful thank you!