[solved] sun path component warning

Hi, I’ve updated my LB+HB, but the sun path component is still giving a warning.

Am I missing sth here?

What do we need to pay attention when updating LB+HB using the update components for both of them?


sun_path.gh (447 KB)


Re-insert the component. Worked for me.

The component was updated recently changing some of the outputs. That’s why for such a cases there is need of reinserting.


Thank you, Abraham!

However, I wonder if a manual replacement is needed in this case, does it defeat the purpose of using the update components for Honeybee and Ladybug?

Yes it is.

If you search in the group you’ll find that this issue has been discussed plenty.

In the development of the components sometimes they change the amount of input/output items. When that happen there is no other option than reinserting such components!!

Fortunately normally they are not so many.

Now, think about the alternative. Would you prefer to do that for ALL updated components. I’m sure you are not.

So i think we all should be thankful with Mostapha and Chris for bringing this update possibility, EVEN when there are cases when you have to do some of the work yourself.

Hopefully in the future they will overcome this issue. Or maybe any of us will collaborate to find the proper solution. What do you say?



Yes, it is required in this case as I added a new feature that changes the legendPar on the sunpath to be able to accept data trees of different parameters for different streams of connected annualHourlyData.

As Abraham says, we can only automate the changing of the python code inside the components. We can’t automatically change the inputs and outputs of the component and so, when these inputs or outputs change, you have to do the work yourself. And, even if we could automate this changing of inputs/outputs, your updated components with changed inputs/outputs would still probably not work since we may add a new input and this shifts all of the other inputs on the component down such that previously connected inputs are now connected to a different input. We don’t change these inputs/outputs often but asking you to replace them manually when it happens is just a part of the many responsibilities that come with the power of syncing to the github.


Dear Abraham and Chris, thank you very much for the detailed clarification!

However, I still got this type of warning for the Import epw component every time I open the GH file attached, although I have updated ladybug and honeybee, re-inserted ladybug-ladybug and honeybee-honeybee, replaced the import epw component manually and reconnect it with other components, and restarted Rhino and Grasshopper …

Reconnect the panel component with import epw component or disable-enable the import epw component can make the warning goes away, but it’ll come back next time I open the file…

Can you kindly advise what else I shall do to prevent this warning from showing up again?



This is a different issue but update. The warning is telling you to let the LB fly first.

For those cases just select the LB_LB and HB_HB and send them to the back (ctrl+B). And save the file. Next time you open the file it should execute FIRST KB_LB and HB_HB so the other components won’t complain.

If you stay in the same session, disable/enable LB (ctrl+E) and then do the same for the importEPW (and other that are complaining about letting LB fly).


Thanks for explaining, Abraham. I really have to make a video that explains the update process.


To clarify about when you need to manually update a component:

You only have to manually update a component if the inputs/outputs have changed since a previous version. Ladybug_Ladybug and Honeybee_Honeybee should almost never have such a change and so there is no need to drag it onto the canvass again.


Thank you, Chris, for the detailed clarification!

Thank you, Abraham, for explaining the “send to the back” operation to solve the problem I encountered!

May I ask why send a component to the back will ensure it is executed first next time the GH file is open? (Maybe I should ask this on the general Grasshopper forum, anyway, glad to hear your advice!)

When you open a GH it starts executing from the “older” component to the newer (simplistically saying). So in your case sometimes it executes first, say, the runE+ before the LB_LB/HB_HB and that’s why they give errors: becouse some of the definitions in the “home” library are missing.

Sending those to the back means that they will be the “older” and will be executed first.

Very rough explanation but i hope it helps.


Yes, definitely helpful, Abraham!

So, to ensure the core library components LB_LB and HB_HB are executed first, let’s make them look “older” as they are “senior” by putting them in the back stage so that they’ll walk to the front stage first the next time the curtain is unveiled … (I think I need to get some sleep…)