Some problems with E+ honeybee simulation

Hi everyone,

I’m trying to do some energy simulations with honeybee. I usually use Diva but in last weeks I have started with Honeybee.

I’m trying different work-flow to simulate various types of shading devices.

In file attached you can find all the different attempts. Unfortunately I have some problems with these simulations.

    • The first problem is related to EP Construction components: You need a newer version of ladybug to use this component… so I can’t create any new materials.

I have tried to use the update components but it doesn’t run and produces this error:

Downloading the source code…
Removing Old Version…
Runtime error (Win32Exception): WindowsError
Traceback:
line 235, in main, “<string>”
line 264, in script

  1. (Red Box) I have simulated a box with a single window facing south. Both with or without shading (and different shading combinations) I obtained always the same result. I used the window shade generator component and seems It is working well.

What is the problem?

  1. In the box 3, I have only changed the approach to define the thermal zone. The E+ component gives me this error: Solution exception: ‘hb_EPFenSurface’ object has no attribute ‘blindsMaterial’. I don’t know what is the problem.

At the end, I tried to simulate a complex geometry shading device. As you suggest, in other post, I used HBContext component but during the E+ simulation compares this error message: **‘None Type’ object is unsubcriptable. **Maybe the geometry is too complex or something goes wrong with the mesh?

Thank you for your availability and help. And sorry for too many questions.

Bye

Andrea

HB attempts.gh (2.23 MB)

Andrea,

You didn’t internalized all of the geometry. Some parts are missing. Do internalize and upload again.

-A.

Sorry.

In attached you can find the right version.

Thanks

A

HB attempts.gh (2.23 MB)

Attached a working file.

Basically i updated manually some of the components (seems to be that this happens a lot lately).

For your 3rd case are you aware that the external shading is not dedfined since you disabled the boundary surfaces component? I enabled it and it takes a lot to solve. Creates 54000 surfaces!!!

-A.

HBattempts_AY.gh (2.23 MB)

Thank you so much.

Now the components works well.

I have tried to resimulate the energy needs, with different setting (no shade and different shading device configurations) but the results don’t change. Is the workflow correct?

About the complex shading, I kept it enabled because it takes a lot to start when gh file starts. I enabled it for the simulation. I know that it takes a lot to solve.

Do you know some technique in order to reduce the number of surface? or other method to evaluated it? Doesn’t the simulation run due to the surface number?

Thanks in advance

Best,

Andrea

Simulation1.gh (1020 KB)

I would recommend you to set a schedule for the blinds and be sure that the setpoint for the blinds to be on. You set 10 w/m2. I suspect the blinds are always on because of those conditions and then you don’t get any change in the results.

Keep in mind that the geometry the component is giving you is not relevant for the blinds. Only when you use the shadeBreps output as context.

Don’t know what to suggest to reduce the number of surfaces, beyond what Chris suggested in a different discussion. For your case it is not very effective. Maybe i’ll use simple surfaces parametrically controlled.

-A.