The error:No .eio file was found adjacent to the .csv _resultFileAddress.results cannot be read back into grasshopper without this file

Hi,

When I run honeybee to carry out energy simulation, the readEPResult component does not work and the error information is “No .eio file was found adjacent to the .csv _resultFileAddress.results cannot be read back into grasshopper without this file.”

What is wrong?

Best

My friend and I met the same issue recently. There could be several reasons. I installed the EnergyPlus again and the problem fixed. My friend use “splitface” commend in Rhino to split the surface in each adjacent brep, and the problem fixed. You can try to connect a panel to " read me" to see what happened to your model.

Best

Hi Chenyang,

Thank you for your suggestions. I think the EnergyPlus has been installed correctly as another model can work. The “creatHBzone” component showed a closed berp had been generated. All of the geometry elements are planar surfaces.

So, I wonder what is the problem.

Best

As Chanyang said this means the simulation hasn’t run correctly. Have you tried to read the “report” output of runEnergySimulation component?

Hi Mostapha,

Here are several lines of the report. Does the “[2 of 6] No context surfaces” mean my geometry model is not imported to the Energyplus correctly?

  1. Analysis period is from 1 JAN to 31 DEC

  2. Between hours 1:00 to 24:00
    2. Current document units is in Meters
    3. Conversion to Meters will be applied = 1.000
    4. [1 of 7] Writing simulation parameters…
    5. [2 of 6] No context surfaces…
    6. [3 of 6] Writing geometry…
    7. [4 of 6] Writing materials and constructions…
    8. [5 of 7] Writing schedules…
    9. [6 of 7] Writing loads and ideal air system…
    10. [7 of 7] Writing outputs…
    11. …
    … idf file is successfully written to : c:\ladybug\Freeformtower_IDF\EnergyPlus\Freeformtower_IDF.idf
    12.
    13. Analysis is running!..
    14. …

Done! Read below for errors and warnings:


  1. 16. Program Version,EnergyPlus-Windows-64 8.1.0.009, YMD=2015.04.04 23:39,IDD_Version 8.1.0.009
    17.
    18. ************* IDF Context for following error/warning message:
    19.
    20. ************* Note – lines truncated at 300 characters, if necessary…
    21.
    22. ************* 577 Zone,
    23.
    24. ************* Only last 1 lines before error line shown…
    25.
    26. ************* 578 Freeformbuilding
    27.
    28. ** Warning ** IP: IDF line~578 Comma being inserted after:" Freeformbuilding" in Object=ZONE
    29.
    30. ** Severe ** Out of range value Numeric Field#5 (Type), value=0.00000, range={>=1 and <=1}, in ZONE=FREEFORMBUILDING
    31.
    32. ************* IDF Context for following error/warning message:
    33.
    34. ************* Note – lines truncated at 300 characters, if necessary…
    35.
    36. ************* 586 BuildingSurface:Detailed,7341.

Hi 627170337,

Because of the severe error there, we know that you energy siimulation is not being run correctly.

Unfortunately, the error that you are getting in the report is one that is not easily understood unless we have your GH definition. If you upload it, we can probably figure out how to fix it.

-Chris

Hi Chris,

Thank you for your response. I have uploaded the GH definition.

By the way, when I try to divide the building form into several layers, the panel shows the brep is open. How to divide the building form into several layers and get a closed brep?

Thanks a lot.

Energy simulation problem 0406.gh (206 KB)

Your components were very very old. Update to the most recent version and everything runs fine (find a working GH file attached). Be warned that your complicated geometry takes EnergyPlus a very long time to run (over 20 minutes on my good computer).

-Chris

Energysimulationproblem0406_CWM.gh (491 KB)

Hi Chris,

Sorry for my late reply. I just came back.

If I update the version of Honeybee, dose the file used the old version components still work?

Thanks a lot!

Best

Han

It depends. In some cases it should still work. You can use the update component also to update all the components inside your file. There are caveats with the process and you still need to replace some of the components manually but it can potentially save you a lot of time.

Mostapha

Hi Chris,

I also get the same problem, I updated all the components and EnergyPlus.

Thanks.

p.s. please find attached the files.

Room 1.3dm (297 KB)
BLevitt_EnergySim.gh (455 KB)

Hi Mostahpa,

I also get the same error.I Updated all components and EnergyPlus.

Thanks in advance.

-N

BLevitt_EnergySim.gh (455 KB)

Nite,

Did you check the report out of the Run Simulation component to see what was causing the E+ simulation to fail?

-Chris

Nite,

Your components were not all up to date. Attached is a fully up-to-date file. It’s failing because your context geometry is inside your zone.

-Chris

Added Warings to Run Sim.gh (469 KB)

Hi Chris,

Thanks you.I don’t know why it shows that the component are old, I updated all last week.

It is still not working on my computer.I guess this time it is failing because I have no windows.

Thanks,

N


ReportCBL.docx (19.2 KB)

I ran into this error as well. I fixed it by deleting the spaces in my file name. I have also found that Honeybee sometimes has trouble reading the separator that the “concatenate” command creates internally. Add the separator character manually and it works fine.