The skyVizualizer componet is automatically became red

I’m sorry to bother you all, I would like to ask a question
I connected the location of this input(like the picture below), the skyVizualizer componet is automatically became red. . . I have not made any other operation, the 0.059 version as the same problem.
Can any friend tell me why? how to solve. thank you all.

Liu,

You probably are using a mix of new and old components.

Attached a working file.

-A.

SkyVisualize.gh (369 KB)

Thank you for your comments

but these componets(like the picture ) are the same version.

and your document I was opened it …they are the same problem too on my PC.

What is the error (look at the top right balloon)?

-A.

just this one-----1. Solution exception:index out of range: 0

Can you open the component (double click), and press the test button?

Copy/Paste the comments you get.

-A.

YES,thank you again for your patience my friend

here is the test result :

Runtime error (IndexOutOfRangeException): index out of range: 0
Traceback:
line 126, in <module>, “C:\Users\Administrator\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins\IronPython (814d908a-e25c-493d-97e9-ee3861957f49)\settings\lib\ghpythonlib\components.py
line 117, in __build_module, “C:\Users\Administrator\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins\IronPython (814d908a-e25c-493d-97e9-ee3861957f49)\settings\lib\ghpythonlib\components.py
line 1965, in calcFullSky, “<string>”
line 369, in main, “<string>”
line 434, in script

I’m wondering if I need to install the ironpython component, so I installed it manually. And I have installed the latest version of Python for GH

Which release service (SR) version you have of Rhino?

I’m suspecting you have an older version of Rhino. It should be SR10 or above (as far as i remember).

But now i will wait for Mostapha’s/Chris’s diagnostic here.

-A.

My RH’s version is RH5.0SR12 64bit

I think this is the lastest version for RH

I also gradually to eliminate the possibility of some myself error,

But there is no way to solve that …so, I’m get here to bother you