Troubleshoot: gridbased Daylight sim

This worked yesterday but I updated this morning to solve another issue and now it doesn’t.

Can someone explain what the error is from and how to make it work?

Thanks so much.

Halp.gh (497 KB)

Ginger,

Reinsert the component manually. That will fix he issue.

-A.

Thank Abraham! What do you think is the best way to let the users know about this! Apparently the warnings are not working as expected. Maybe we should add a remark to the update components and make a clear statement about the limitations.

Hmmm …

Yes. People think that the updater component is enough. I know there in “no way” by now to overcome the limitation of updating components that changed definitions.

Maybe, if possible, not updating those? Just add a warning that they should be reinserted from the tab group? Also not good, but may make people more aware …

Chris wrote some days ago he will make a video explaining the process of updating and how to deal with issues.

Also (maybe) on the main page of the group write about the problem and how to deal with it?

Not an easy task to deal with.

-A.

Thanks!

[Why this website doesn’t post the full reply!]

Leaving a note and giving a warning is not actually that hard to implement. I was also thinking to remove them from the official release and keep it in a different folder for developers but that has its own drawbacks.

Oh no! Don’t do that :slight_smile:

I don’t think this is a live/death issue in order to separate versions. Moreover, the versions are separated already (official and github). So people updating from the git should be a bit more aware of the compatibility issues that can be found from the update process. I think that having another “version” for developers will fall in the same hole. People will download this version and will get into the same situation.

In short, i don’t think it is so bad users get into this since at the end they get the needed support her in the forum. I’m sure thay won’t get there for a second time. In a way they 9we) get educated.

Makes sense?

-A.

Hi Abraham. Agreed! I think I will just add a remark to the component to remind them the limitations. I think I have been dramatic about this issue.

Follow up question. My grd analysis recipe only works if the simulation type is set to radiation. If this is just me, how do I fix it? If it isn’t why is it an option to change the simulation type? Are the other analysis recipes prefered for illuminance or luminance calcs?

Will be useful to upload your file. Otherwise, hard to say. It is supposed to work.

-A.

I guess you’re using cumulative sky with the recipe. You need to use one of the other available skies if you want to get luminance and illuminance values.

Solved! Thanks. :slight_smile: Sky type. So obvious in retrospect.