Versioner 1.4.2 - Runs forever

After updating with Versioner 1.4.1 i got a warning (orange component) saying that i should update again with Versioner 1.4.2.
I’m trying to do that but the Versioner is running forever, not ending the process, so i need to kill Rhino.


The previous post was done when Rhino was run as administrator.
Right now tried to run as regular user and the update succeeded. It opened a command window that i need to press any key to close, but it worked.


Hi @AbrahamYezioro Did versioner work without administrator rights?

Yes it did @Asisnath ,
But with version 1.4.2.

1 Like

Yes, sorry that I forgot to let both of you know that we implemented the ability to request Admin privelges when you run the Versioner (as opposed to having to remember to open Rhino in Admin mode). In the very latest version of the Versioner (1.4.3), we only do this when Ladybug Tools has been installed in “Program Files”, which necessitates the use of Admin privleges. Otherwise, the Versioner works just like it always has.

The improvement is thanks to @MingboPeng , who put together an executor that allows us to request admin access.