Weird radiation results

Hi all!

I’m getting some weird results running a solar radiation study. When I run a study at the 20th of june at 12.00 noon, you’d expect a lot of sun, but the results are 0 (nighttime).

If I go to 16.00,17.00 i finally start getting results, but the most ‘warm’ results i get when it’s midnight around 1.00 2.00.

It appears the time is shifted by 12.00, what might I be doing wrong?



17.00 (first results, seems like sunrise)

2.00 (midnight, but seems to be noon)

Hi Arie,

These are some weird radiation results indeed! I can’t tell exactly what the underlying problem is from your images. If you upload a GH definition of your file, I can investigate deeper. Also, it would be great if you could also upload the weather file that you are using.


Ladybug uses, the latitude, longitude and time zone, by reading the first row of epw weather data file.
If this this row is not correctly compiled, Ladybug could put the location in another part of the world
I suggest you to check the row of your weather file with one downloaded from the energy plus weatherdata site…


Chris, Giobuttu,

Thanks for the fast response!

Chris: I uploaded the def and the epw file. Just insert a surface in the input to see the results.

Giobuttu: I downloaded the file from here (this is were the LadyBug_download_EPW component takes you). Supposedly mexico city has coordinates, latitude: 19.431255, Longitude: -99.135475 (here). The Epw file says: latitude: 19.43, longitude: -99.08, so they seem to match up.

Anyway thanks guys for taking a look! (119 KB)
MEX_Mexico.City.766790_IWEC.epw (1.48 MB)


I can’t seem to replicate your error on my machine. In the attached image you see that everything is working fine for me:

Also, in this image, you can see that everything is fine in the weather file’s latitude and longitude.

Perhaps, in your first run of the Radiance GenCumSkyMTx, something was interrupted or corrupted? Are you able to run the attached GH file on your machine and get a correct result?

-Chris (102 KB)


I think it has to to with the gendaymtx.exe.

First when i run the simulation I got this error:

Saying that it couldn’t download the gendaymtx.exe file. So I manually downloaded this file and put it in my appdata/roaming/ladybug/ directory.

Then it seemed to work, it showed the command prompt that it generated the sky etc and that window disapeared after couple of seconds etc. but then when I run the simulation I still get these results:

This is your exact defenition I didn’t modify anything.

Could you upload the gendaymtx.exe? Or how did you bypass the first error I had, that it couldn’t download the gendaymtx.exe?



Here is the gendaymtx.exe file that I am using. Try copying this to that appdata/roaming/ladybug/ directory on your computer and see if you still get the error.


gendaymtx.exe (19 KB)


Thank you so much! that did the trick!

Were did you get your gendaymtx.exe?? If you look closely yours is 19 kb, and mine is 21 kb.

I downloaded mine from the location in the python component, it links you to a dropbox location (here), but that one generates the strange results… I don’t know if I’m the only one, maybe you could try to replicate by temporarly replacing your 19kb one with the 21kb and see if that also happens to you?

Anyway thanks again!

Glad to hear it!

I think that my gendaymtx.exe was downloaded a few months ago when I first installed Ladybug on my computer after a reinstall of windows. You are right that the two are different sizes and the 21 KB one must be more recent.

I tried using the 21 KB gendaymtx.exe and I was able to replicate the weird radiation results. I also noticed that the batch file runs a lot quicker with this 21 KB version, which makes me think that an error is occurring.

If I remember correctly, that link is on Mostapha’s dropbox and he should be able to change it. Mostapha, did you update the gendaymtx.exe link in the recent past at all? What was the reasoning behind it and would you consider putting the old one back in light of this?


Hi all,

Chris, There are two versions of genskymtx and 21kb is the newer version ( Can you check and let me know what is the error that happens on your system with the newer version?

I wanted to send a post and ask everyone to update their Radiance to the newest version (4.3.a) which has the recent bug with pfilt fixed but before I do that can you install the newest radiance, copy gendaymtx from c:\radiance\bin to ladybug folder and let me know if it works fine on your system. You can download it from here: (

Hey Mostapha,

I installed the most recent Radiance (v. 4.3), copied the gendaymtx from c:\radiance\bin to ladybug folder and I still got the weird results:

It seems that we have found a major bug in the most recent version of Radiance. Perhaps it is best that we revert to the older gendaymtx.exe and report the issue to Radiance team?


Chris, Mostapha,
I also have the most recent version of radiance installed, v4.3., when I was getting the strange results. It has to do with the gendaymtx, the old one (19kb) takes a little longer in calculating the sky, the new one (21kb) seems to skip some passes as it seems to calculate (to) fast. Thanks guys and have a nice weekend we have an hour extra :slight_smile:

Thank you both. Let me check and see what is going on. If I am not mistaken the extra hour in the US will come next weekend. For now I have a combined jet-lag with sleeping disorder which means I will be around for awhile!

It works totally fine on my system and I am also using the new version.

Chris, can you confirm that selectSkyMtx component returns all zeros on your system? If that is the case, can you remove echo off from bacth file, add a pause at the end of file and run it again and see if there is an error?



It is not the the selectSkyMtx component returns all zeros when you run an annual simulation. It is only when you run it for a single hour that should be sun-up. Try changing the HOY of selectSkyMtx to 12 and you should see the error. Over the whole year, the component is still relatively good.


Ah… Got it! Thanks for clarification. I can see why this is happening. There is a heading added in the new version. Let me see how can I get it fixed. Thanks again.

Awesome! Glad to be of help.

Can you guys check the attached file and let me know if it works fine? It should work with both versions of gendaymtx with no problem. (83.3 KB)

This one runs perfectly on my machine with the 21 KB gendaymtx.exe. What was it that you changed, Mostapha? I may need to make a similar change in my solar adjusted temperature component.

Hey Chris, Sorry for the late response.

Here are the changes:…

I made few changes to check for the header and if the header is there consider passing the header. It looks to work fine but I want to test it more before sending an update note. Will do some validations tomorrow evening.