Window Shade Generator: Simulation Result output is same for Blinds on/off schedule

Hey All,

The simulation output for blinds schedule in window shade generator component gives out similar results, it is not affecting the solar gains or operative temperature. Could someone take a look at my file and let me know the issue?

Thank you,

Vinu

blinds.gh (629 KB)

Vinu,

See this issue:

https://github.com/mostaphaRoudsari/Honeybee/issues/527

You should use the OpenStudio component for the time being and I will try to put back the functionality into the ‘Run Energy Simulation’ component tonight.

-Chris

Vinu,

I put back the ability to run shades with the ‘Run Energy Simulation’ component. This doesn’t lessen my suggestion that you should start a transition to using the OpenStudio component since this will ultimately enable you to model full HVAC systems.

Please sync with the github and let me know if it solves your issue.

-Chris

Hi Chris,

Thank you for the help, I updated the honeybee on git hub but its not working(the output results are same). I tried it in open studio but it is showing error. My model is ready for user study (not this one, it’s a bigger file), I just need this one to work.

I have attached my file. Could you look at my file? I will try open studio again!

Thank you,

Vinu

blinds.gh (629 KB)

Vinu,

Thanks for testing and reporting. I took some time to go through your file and part of the issue was the result of a bug in Honeybee and part of it was because you were over-writing your CSV file and Energy Simulation Results by calling both IDF files and CSV schedules by the same file name.

The Honeybee bug is now fixed in both the EnergyPlus and OpneStudio components. You can find your working gh file attached.

Thanks again,

-Chris

FixedCSVSchedBugs.gh (779 KB)

Thank you very much Chris! This is of great help! It’s working :slight_smile:

Vinu

Just another question, Is there a way to output only the idf file without opening the energy plus in open studio , I am running parallel simulation. here’s the link of the conversations we had

http://www.grasshopper3d.com/forum/topics/running-several-e-simulat…

and the image of parallel simulation that I am using(Mostapha’s example). If I use the run energy simulation component it shows error!

Vinu,

If what you are asking about is whether we can translate the OSM to an IDF but not run the IDF through E+, I think that is a great idea. I wouldn’t want to implement this capability on the ‘Export to OS’ component because I imagine that, more often than not, people just want to simulate and the extra boolean toggle could be annoying. However, I can add it on the Re-Run OSM component and I have opened an issue for it here:

https://github.com/mostaphaRoudsari/Honeybee/issues/542

Your error results from you not updating all of your components (including HB_HB). Make sure that they are all up to date and it should work.

-Chris

Thank you, run energy simulation is working! I will follow the github link!

Vinu,

I realized that it was just easier to just add an additional option on the Export to OpenStudio component rather than only put it on the Re-Run OSM component.

https://github.com/mostaphaRoudsari/Honeybee/commit/180fed9591481fa…

If you sync with the github, you will notice that you can now plug a “3” into the Export to OpenStudio component and the component will generate the IDF file but not run it through EnergyPlus.

Thanks for the suggestion and let me know if this works well for you.

-Chris

Thank you Chris, I checked the component and it’s working!