Error in OpenStudio Export

openstudio

#1

Hello all!

I am running into some problem with the export to Openstudio component. Everything is fine when I set True to writeOSM but when I tried to run it, warnings and severe errors are shown. I’m uncertain where the problem is!

Thanks!

Best,
April


#2

HI @aorukaya,
Can you please post what are Severe warnings from your simulation? Alternatively, you can post the bare minimum version of your GH file with geometries internalized please.


#3

Hi @devang

I am using the tutorial file for Honeybee Energy Modeling. The error shows:

  1. Weather Simulation Requested, but no weather file attached.
    However when I input my epw file, it seems to work okay with all my other files so I’m unsure what is happening here.

2)GetNext Environment: Error found in getting new environment

  1. Fatal error conditions occurred. Previous errors caused termination.1-Setting Up Energy Model.gh (649.1 KB)

#4

Thanks for the file. Simply updating the components to the latest version works perfectly fine at my end. Open studio component run without any severe errors.


#5

Hi.

Thanks for the quick response. Updating the HB files? I’ve manually put the zip files from GIthub into my C:/ladybug because I cannot manage to use the update HB component. By doing that I’ve solved previous HB problems, but now I’m not sure what other files I need to update?


#6

Please find the updated file
1-Setting Up Energy Model.gh (672.4 KB)


#7

I used
https://mostapharoudsari.gitbooks.io/ladybug-primer/content/text/components/Update_File.html

component to update the file.


#8

Hi,

Thanks for your response. I was able to update many of the ladybug components but the same problem still occurs when it says it cannot read the epw file. I opened up the file you attached, and when set true to open epwfile, the openstudio components still gives orange warnings. This did not happen for you? I’m unsure what is the problem because the epw file I set true to should work.


#9

Hi I tried moving my EPW file to another path with folder containing no spaces and that seemed to have solved the problem. Thank you.


#10

Why spaces in a file path an issue:
A lot of the new functionality depends on the OpenStudio command line interface. As the command line interprets arguments separated by spaces, if you have a path that includes a space, it will split it and interpret it as two different arguments. It’s a known issue that isn’t a high priority to fix.

If you are using OpenStudio, avoid using spaces and special characters in your file paths.


#11

:+1: :100:

Even if you don’t use OpenStudio it always a great suggestion not to use spaces and special characters!