Black geometry in GH

I have a quite annoying issue for a few days. As you can see in the picture attached, the view from grasshopper is fully black. If I bake this view, the colors appear magically !
This is quite strange because the issue appears with some components and some not :

  • With LB 3D charts - Doesn’t work
  • With Custom Preview : ok
  • With LB recolor mesh : ok but the legend is black !

I wonder if this issue is not concerning Mesh only

I’ve tried :

  • Reset all my settings
  • Check the view propreties in both rhino and GH, and set them to standards
  • Re-installed Rhino6 and GH
  • Updated LB/HB components
  • Certainly others that I miss

This happends only since tuesday. My previous files that perfectly worked don’t display correctly anymore. I suspect this is due to a rhino update I made this week, but I can’t be sure and I don’t know how to solve the problem

Did someone already had that kinf of issue ?
Thank for your help !


You need to turn off Mesh Edge Preview in Grasshopper. Click on Grasshopper canvas and then press Ctrl + M.

Well I did so and indeed Mesh Edge appeared in red but it didn’t fix the issue
I’m quite confused


Here is my GH file which is surprisingly simple (388.0 KB)

Thank you for sharing the file. The issue only happens on Rhino 6. Works fine on Rhino 5. Not much that we (Ladybug Tools) can do about this.

@wim this is a good sample file for the issue that I mentioned before. Do you think we should post the issue to McNeel forum or is it already submitted as an issue?

Thank you for your help,
Shall I post the issue somewhere else ? Or inform Rhino in some way ?

I noticed this also. When you switch to rendered view it looks fine. But shaded or wireframe have issues.
Look also at the legend. Only in rendered view it shows fine.

1 Like

Thanks again, @mostapha. I’ve added this thread to our McNeel internal conversation.

@EmmanuelR, do you know which version of Rhino 6 you were running before your update?

1 Like

Hello @wim,
I’m afraid I can’t but I can tell you that the version I used was the trial version downloaded around the 20th of june.

Thanks for your help

I’ve noticed too for the legend but in my case GH geometry never displayed in rendered view (unless it has already been baked in rhino).
Is there any settings I missed ?

In my case i kind of remember that the legend showed OK on the viewport a couple of versions ago. Right now i’m using Version 6 SR6 (6.6.18177.16151, 06/26/2018). Can’t remember the number …

I played around with the settings on Rhino … but can’t remember what was it. I’ve found some discussions in the Grasshopper discourse, specially some David Rutten comments.

@wim in particular and anyone else that is experiencing this issue,

I am pretty certain that this is a bug in Rhino 6 that was recently introduced. It seems that we have all been experiencing it since Tuesday and I’ve noticed that this is around the time when the last Rhino 6 update was checked for all of us (assuming that you use the default update frequency of the Service Release):

To give a more detailed description of the issue, the meshes are not totally black but just have very dark colors (it seem’s they are displaying at somewhere around 1/100th of their usual lightness). If you have a good screen quality, you should be able to make out some minor color variations in the mesh image here:

The correct color properties are there in the mesh and it seems to only be an issue with their display.

Baking the geometry and going over to rendered view seems to be the best recommendation that we have come up with on this thread so far (short of going back to Rhino 5). So this is what I would recommend to everyone for the time being.

@wim , let us know if there is anything else that we can do to help get the issue solved.

I was in doubt of opening a new discussion or add to this one. Well …
This is not black geometry but related to display issues.
I’m checking a zone geometry types with the HB_decomposeByType component.
Next image shows that the Preview is OFF for the component. Only the Windows are shown with the PreviewGeometry. The color of the window was set with the ColorSwatch as blue. The image shows that for Wireframe and Shade display some windows are rendering as expected and some are not (white or magenta colors).

Next image, following above description, shows Rendering display. For this case ALL geometry shows, even though only windows are supposed to be.


Credits for the geometry to @bussey.philip. I was checking his discussion here, so decided to continue with this thread.

I’ve found another thing here following @chris comment on baking geometry.
If you bake the geometry it shows as already said. But if you delete the baked geometry on Rhino, THEN it will show fine from GH in the viewport on all display types (wireframe, shade, render).


I might have a wierd solution to view the meshes color properly.
I just noticed that if I forgot to hide preview of Cutom Previews linked to the Decompose Based On Type component (anyone follow me?), then you can see colors through surfaces who do have transparence. Here is the result :


Well we’re not going any further but I hope it can help you @wim to find where the issue is coming from.

So it seems Rhino 6 just pushed an update but this issue still is not fixed.

If we can’t get this fixed soon, I’ll have to write a workaround for the next release of Ladybug that bakes all meshes in to the scene and brings them back to GH. This will make me really sad.

@wim are there any updates on your end or anything that we can do to help you here like providing a snippet of code to reproduce the error?

I found a cleaner workaround (in lieu of baking the geometry) for those still experiencing the issue.

You can just pass the colored mesh through a “Deconstruct Mesh” Grasshopper component and then pass the result into a “Construct Mesh” Grasshopper component like so:

@wim , Knowing this, it seems likely that the bug is with the VertexColors setter in RhinoCommon, which is what Ladybug is using to color the mesh. From what I can see in the SDK docs, it doesn’t seem like this property is deprecated:

Perhaps another way we can fix this is if we know what methods are being used to assign the mesh colors in the Native GH Construct Mesh component, we can use that instead.

@chris @wim @EmmanuelR ,
I just changed Ground plane settings to Custom and display works without any problem.


Following @OmidmRashidi, which showed the Rendering option on viewport, i checked the other 2 (Wireframe and Shaded).
Here is the setting i gave to get the display right:



Wonderful! Thanks for finding this solution @OmidmRashidi and thanks for confirming it @AbrahamYezioro . This makes any fix that I’d have to implement on our side a lot easier.

So, if we don’t hear any word from McNeel that the bug has been addressed, I’ll just have Ladybug_Ladybug automatically change this Rhino setting whenever it runs. So, whether the solution comes from McNeel’s end or ours, it seems we are just days away.

1 Like