Getting Ready for Rhino V8

To Be Specific

Runtime error (DirectoryNotFoundException): Could not find a part of the path 'C:\HB_Sim\annual_daylight_enhanced\__logs__\logs.log'.

Traceback:
  line 357, in luigi_execution_summary, "C:\Program Files\ladybug_tools\python\Lib\site-packages\lbt_recipes\recipe.py"
  line 398, in failure_message, "C:\Program Files\ladybug_tools\python\Lib\site-packages\lbt_recipes\recipe.py"
  line 146, in script

Thanks, @tay.0 . I’ll try to test this in Rhino 8 soon. I think we’ll likely need to do a separate release of Ladybug Tools for Rhino 8 given that so much has changed with the way that Python runs there.

Thank you @chris , I’m doing my own tests for fun as well, consider me for any help needed testing things out.

1 Like

Hi Tay -
I haven’t tried this myself but was wondering if you have tried running Rhino 8 under the 4.8 runtimes.
-wim

Hello @wim
Indeed, I consistently utilize the DotNetFramework for my runtime environment, primarily due to my extensive use of Rhino.Inside Revit. It seems I’m indefinitely stuck to it!

Update:
I got Honeybee Annual Daylight Hours + ASE recipes to work by doing the below:
1- completely uninstall Ladybug Tools installed from Food4Rhino, delete all the libraries, dependencies, radiance, open studio.
2- install pollination for grasshopper. (I like the new installer way more)
3- Load the plugin from rhino manager by pointing to the rhp placed under the rhino 7 packages.
4- restart. working for now (except with the stamp on the icons which I don’t care about that much).

Now It is more powerful with Rhino 8 , better display modes, and the new Grasshopper objects makes it easier to reference, update and bake rhino objects within grasshopper,

1 Like

Hey @tay.0 ,

Ah, now I think I know why you got that error and I actually don’t think that it’s related to Rhino 8. It’s because the latest Pollination installer is using Python 3.10 but you had an older Food4Rhino installation that you’ve been updating with the LB Versioner, which was still using Python 3.7. In other words, I think it’s the same issue that this user experienced on Mac (where we have no single-click installer):

You’ll see that you get the same error message. I think the fix I pushed yesterday should also address your original case. But using the Pollination single-click installer is also a sure way to always fix it.

And, as for this:

I think we’ll hopefully find a solution to get rid of this before Rhino 8’s official release. We’re working with Ehsan on a solution now.

1 Like

@chris
I witnessed this issue few months ago (before the pollination install), I think it is related to the new Cpython editor that installs python 3.9 alongside ironpython. not sure what is the root cause of this conflict.
anyways I really appreciate your team’s work on building ladybug as .rhp package than the previous assortment of tools, it makes it easier for everyone to install and move on.
cheers,

@chris
To confirm this, starting the new scripteditor will automatically download Python 3.9 components which will stop the recipes from running.

and deleting the python components from %HOMEPATH%.rhinocode\py39-rh8 will fix the issue.

So, it is essential to work with @eirannejad to get this sorted out.

1 Like

Thanks, @tay.0 ,

@eirannejad and I just figured out what this issue is and it results from the fact that loading the new Python capabilities of Rhino 8 overwrites the PYTHONHOME environment variable, which messes up all of the LBT components that use the native Python subprocess module to call the Python that we ship with Ladybug Tools. So, before the Rhino 8 Python libraries are loaded, it all works but, afterwards it is broken.

Thanks to @eirannejad , I know how to fix it now and I’ll begin pushing some fixes in the next few days. It may take a bit of time to track down all of the cases where we use subprocess. I’ll post back here once all of the places I know of are fixed.

4 Likes

I posted the solution here

1 Like

FYI, @tay.0 and @eirannejad ,

I finished integrating all of the fixes into the latest development version of the LBT plugin, which is available with the LB Versioner. So there’s no more OLD tag in Rhino 8 and all of the cases where we use subprocess to call an external Python library succeed.

I’m just waiting on a few updates to our single-click Pollination installer and then I’ll make an official post that includes an updated installer on Food4Rhino

4 Likes

That’s awesome! Woot wooooot! :train:

1 Like

Thank you both for the quick turnaround. I’ve been enjoying the new ladybug tools for a week and it works great with V8!

1 Like

Hi I just installed V8 and everything is broken for me help!!

Hello @alcy6600ff

Do the following:

Step 1: go to C:\users<YOURNAME>.rhinocode
Step 2: delete the folder called something like rhpython39
Step 3: download and install Ladybug tools 1.7 from food4rhino
Step 4: run the versioner and restart rhino

This should solve your problem.

1 Like

image
i’m still getting this issue :sob:
Reinstalled a billion times, about to go into a meltdown since I upgraded to v8 from 6 JUST to try to fix my issue I had prior…

You are running a legacy version of butterfly; I don’t think it is in active development anymore.
@chris can you confirm?

I installed from new Butterfly, the 1.7 one. Ran it like a billion times uninstall reinstall uninstall reinstall…

I don’t think there is a Butterfly 1.7. This topic discusses Ladybug Tools + Honeybee + Dragonfly.
do me a favor and let me know
1- Place a component from Ladybug (not Butterfly)
let me what version is reading on the bottom of the component
Animation

Hi @alcy6600ff ,

The latest development version of the LBT Plugin that you can get with the LB Versioner works in Rhino 8 but the LBT 1.7 stable release does not work in Rhino 8. I’ll push a new installer to Food4Rhino in the next week or so that is fully compatible with Rhino 8.

Butterfly was last released in 2019 and has not been maintained since then. As you see on Food4Rhino, it was only ever tested in Rhino 5 and 6. Granted, I think you can likely get Butterfly to work in Rhino 8 if you copy this folder:

C:\Users\[USERNAME]\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\butterfly

To this location:

C:\Users\[USERNAME]\AppData\Roaming\McNeel\Rhinoceros\8.0\scripts

But, again, Butterfly has not been maintained since 2019 or tested in Rhino 8. So proceed with caution.

And, thank you, @tay.0, for helping here. You should definitely answer his question, @alcy6600ff , if you want to get LBT working in Rhino 8.

1 Like