Installation Error OpenFoam Windows 10

Using .tgz requires the use of Ubuntu. That seems another challenge. Will it be ok to try the installer.exe for OpenFOAM v1706?

Hi @devang, yes I used .exe!
Good luck

Same error on a Windows 10 PC with AMD Ryzen 7 1700X Eight-Core Processor and 16 GB of installed RAM. I have also tried to install the v1706 of OF without results. The image below is referred to the OpenFOAM_Start for the v 1706

I tried also to use this in docker:

cd \c
cd ‘Program Files (x86)’
cd ESI/OpenFOAM/1612/Windows/Scripts
docker load -i of_v1612plus_centos66.tar
For version 1706+ the last line will be
docker load -i of_v1706_centos73.tar

but it stops me to the second line:


How can I solve?

There were no errors in OpenFOAM create? May be restarting the machine can help.

When I click on the OF_Env_Create appears the following message: “yo may need to re-run the ….”

I have restarted the pc but the result is the same

Which version of Virtual box you’re using? For windows 10. Most people have had good luck with the latest version of virtual box and openFOAM 1612

I solved by modifying this line:

with the following:
$ cd Program\ Files\ (x86)/

Then I have started first the Docker Quickstart Terminal as an administrator and then the OpenFOAM_Start as an administrator:


For a complete information: I have also upgrade the Virtual box with the 5.2.8 r121009 version.

I am not sure if open foam is running correctly. Please check if virtual box is running. When openFOAM is running successfully, this is how it looks.

Virtual box is not running::sweat:

Please try the following;

  1. Start virtual box as admin
  2. Turn it on
  3. if it works, power off
  4. OpenFOAM Start as admin

It might be required to do this a few times.

Meanwhile I have tried to restart the pc, then I have started docker and OF and verified the VB:

Just to be sure that it’s working, please try to write and run Blockmesh in Butterfly. If openFOAM is not working correctly it will throw an error. Or else, swoosh

I have followed also your suggestion. It works properly:

The blockmesh doesn’t work:

  1. Solution exception:Failed to find container id.Do you have the OpenFOAM container running?
    You can initiate OpenFOAM container by running start_OF.bat:
    C:\Program Files (x86)\ESI\OpenFOAM\1612\Windows\Scripts\start_OF.bat

I remember that I installed the v1706 because I have read from here that butterfly supports the v1706:

I have downloaded the ver 0.0.04 for food4rhino

I too run into this error. What works is to power off VM. Close OpenFOAM and start it again. Also, please run rhino as admin.

I am not sure the version on food4rhino supports the latest version of OpenFOAM. In order to install the latest version of butterfly you’ll need to do the following.

  1. Remove Buttefly user objects from Grasshopper
  2. Go to C:\Users\YOUR USER NAME\AppData\Roaming\McNeel\Rhinoceros\5.0\scripts
    3 Here, you’ll find 1. butterfly and 2. butterfly_grasshopper. Remove both the folders. Restart rhino & GH
  3. Download this repository as a zip by clicking on clone or download
  4. find a folder named “butterfly” and copy it to the path in step 2
  5. Download this repository as a zip by clicking on clone or download
  6. find a folder named “butterfly_grasshopper” and copy it to path in step 2
  7. In the last downloaded repository, also find userobjects for butterfly and copy them to userobjects folder or drag and drop them to the grasshopper canvas.

This should give you the latest version of butterfly.


Thank you @devang!
Now the blockmesh works:

Glad it does! :grinning:

Ok, now there is another issue:
I have used the example file taken from the …butterfly-plus-master\plugin\grasshopper\examplefiles folder.

The caseFromGeos component creates the case:

The components blockmesh and snappyHexMesh seem to work properly:

But the Butterfly solution component reports a Foam fatal error:

Cannot find file “points” in directory “polyMesh” in times 0 down to constant

Solved, simply by adding the boolean button setted to “true” to the “run” input of blockmesh and snappyHexMesh components:

2 posts were split to a new topic: meshParams missing